Ability to determine what info form autocomplete collects

VERIFIED WONTFIX

Status

()

Firefox
Address Bar
--
critical
VERIFIED WONTFIX
15 years ago
15 years ago

People

(Reporter: m1scha_m, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20030105 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20030105 Phoenix/0.5

Users should have the ability to determine what information form autocomplete
collects so that someone else who uses their computer and knows the autocomplete 
file format does not have more control over that information than them

Reproducible: Always

Steps to Reproduce:
1. 
2.
3.

Actual Results:  
anytime form auto complete is activated any collected information is readily
available merely by enetering the first number/letter, this included credit card
details.

Expected Results:  
allow the user to determine what information is collected, and or how it is
displayed.

severity scale does not allow for this type of bug

Comment 1

15 years ago
So I guess you're asking for a "form manager" that displays all the information
Phoenix's form manager has collected, similar to the cookie manager?
Summary: Users should have the ability to determine what info form autocomplete collects → Ability to determine what info form autocomplete collects
(Reporter)

Comment 2

15 years ago
That would probably be more of an ideal situation, especially for people who
either share a computer, or people who do not want some material collected, but
still want other stuff displayed. But is it possible in real life?
I get the impression Phoenix, in particular, is trying to restrict the number of
available preferences, ?to look good?, while making users set their own
preferences via user.js. Can form autocomplete differentiate between a credit
card entry, and a series of numbers entered into a Google search. If so, perhaps
one page of prefs could be a series of questions requiring a yes, no, number,
answers which equate to valid user.js entries.

Comment 3

15 years ago
you can disable the feature if it's not to your liking or you can delete your
form data when you're done using the computer. Why are you sharing a profile
with others? Why are you sharing a windows login with others? The Phoenix
developers are not going to implement Mozilla cookie manager-style controls for
form manager.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
Is the WONTFIX status of this bug a WONTFIX for a general purpose Form Manager
or a WONTFIX for some kind of interface to determine autocomplete info collection?

The comment about a general purpose Form Manager was never addressed further.

Comment 5

15 years ago
Taking QA and mass verification of dupe, invalid and wontfix autocomplete bugs.
Sorry for the bugspam.
Status: RESOLVED → VERIFIED
QA Contact: asa → davidpjames
You need to log in before you can comment on or make changes to this bug.