Closed Bug 1883623 Opened 4 months ago Closed 4 months ago

Gamepad isn't detected on GeckoView when it is already connected at startup

Categories

(Core :: DOM: Device Interfaces, defect)

All
Android
defect

Tracking

()

RESOLVED FIXED
125 Branch
Tracking Status
firefox-esr115 --- wontfix
firefox123 --- wontfix
firefox124 --- wontfix
firefox125 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

From bug 1880772 comment #1

(In reply to gman10501 from comment #1)

I have additional testing information.

Bluetooth connection does not seem to work at all, nor detect a controller is connected.

I can reproduce this on Bluetooth connection of Xbox series X controller + Pixel 4a (Android 13).

Keywords: regression
Regressed by: 1624675

It seems to be regression by bug 1624675.

Since sStarted is still false when calling scanForGamepads(), GeckoView
doesn't detect connected gamepad.

After bug 1624675, we use runOnUiThread, then it calls runnable immediately,
so this seems to be regression by it.

And there is no way to write test for this since it depends on real
device.

Summary: Gamepad isn't detected on GeckoView when is is already connected at startup → Gamepad isn't detected on GeckoView when it is already connected at startup

Set release status flags based on info from the regressing bug 1624675

Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/21481abe707c
Detect gamepad correctly when it is already connected at startup. r=geckoview-reviewers,owlish
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: