NNTP error 437 returned from Typhoon news server

VERIFIED DUPLICATE of bug 54911

Status

VERIFIED DUPLICATE of bug 54911
16 years ago
10 years ago

People

(Reporter: munk, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenVMS Digital_Personal_WorkStation_; en-US; rv:1.3a) Gecko/20021210
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS Digital_Personal_WorkStation_; en-US; rv:1.3a) Gecko/20021210

My ISP is using a news server with Typhoon 1.2.3 software. When I am trying to
post a message to this news sever I always get a NNTP error 437. This also
happens with Netscape 7.01 on Windows 98. This beheaviour is something that
started about 6 months ago, before that time I could post using Mozilla or
Netscape 6. It may well be a problem with the Typhoon software.
The producer of the news server software has can be found at:
http://www.highwinds-software.com/
and not at www.highwind.com as you can read in the log file.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
Created attachment 111084 [details]
Complete log file from starting news/mail window to closing Mozilla

Please ignore the URL of the web site of the producer of the news software in
this log file!
The real URL is http://www.highwinds-software.com/
(Reporter)

Comment 2

16 years ago
Some more clarification:
1. I get this response with any news group (using Netscape or Mozilla).
2. When I use the Forté Agent news client on Windows 98, everything is oké and I
can post.
OS: All → OpenVMS
Hardware: Other → DEC

Comment 3

16 years ago
Changing hardware and O/S as the reporter states that this problem is NOT
specific to the OpenVMS versions of the browser (and if we leave O/S set to
OpenVMS then no one will even look at the bug!!).
OS: OpenVMS → All
Hardware: DEC → All
(Reporter)

Comment 4

16 years ago
I have also filed a bug with Highwinds, the producer of the Typhoon news server.
There it has request number 916. Since I am only a customer of one of their
customers, it remains to be seen if and when their support staff will react of
course.
(Reporter)

Comment 5

16 years ago
Netscape developers, this is a major bug in Netscape 7.01 too !!

I got a response from Mr. Carlos Castro of Highwinds software who was kind
enough to study the log file I attached to this bug. His conclusion is very
clear, Netscape and Mozilla are posting to the wrong news server, even if the
newsgroup is not present on the other news server ! 

This is his comment:

---------------------------------------------------------------------------------

Our software does not give the error:
 '441 437 Unwanted newsgroup "xxx"' 
for that kind of error, it gives:
 '441 Posting Failed (Article NOT Posted to a Valid Newsgroup)'

The log attached to the ticket shows the error when talking to 
secnews.netscape.com (which runs Collabra) rather than news.rdc1.ov.home.nl
(which runs Typhoon).

And it apears that secnews.netscape.com does not subscribe to comp.os.vms:

200 secnews.netscape.com Netscape-Collabra/3.52 03615 NNRP ready (posting ok).
group comp.os.vms
411 No such group

The connection ID for news.rdcl.ov.home.nl is 99c080 and the 
connection ID for secnews.netscape.com is 60fa3a8.

2076657800[99c080]: (5390f08) Receiving: 200 @Home Benelux News Powered by
Typhoon (www.highwind.com) (Typhoon v1.2.3)
2076657800[99c080]: (60fa3a8) Receiving: 200 secnews.netscape.com
Netscape-Collabra/3.52 03615 NNRP ready (posting ok).
2076657800[99c080]: (60fa3a8) Sending: POST
2076657800[99c080]: (60fa3a8) Receiving: 340 Ok
2076657800[99c080]: (60fa3a8) Sending: Date: Thu, 09 Jan 2003 20:41:58 +0100
2076657800[99c080]: (60fa3a8) Receiving: 441 437 Unwanted newsgroup "comp.os.vms"

---------------------------------------------------------------------------------

Now this looks like a duplicate of bug 54911, with one important exception. In
that bug description it is stated that the bug appears when the same news group
is present on both news servers. In this bug the news group is not present on
both news servers. That can mean that the bug description in bug 54911 wrongly
assumes that the news group has to be present on both news servers.

Updated

16 years ago
Depends on: 54911

Comment 6

16 years ago
I have marked this bug as depending on bug 54911. I prefer not to mark it as
duplicate since the symptoms do differ slightly. Once bug 54911 is fixed, we see
if this problem goes away, and if it does, then mark it as a dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
The target group need not be present on both servers for bug 54911 to be
applicable. 54911, filed 27 months ago, apparently needs more dupes in order to
get some attention. Fix of 54911 will fix this, so it's the same bug. -> dupe


*** This bug has been marked as a duplicate of 54911 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 54911
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.