Displaced image on maps of page tmb.net

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Daniel Clemente, Unassigned)

Tracking

({regression, testcase})

Trunk
Future
x86
Linux
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WORKSFORME?], URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030109
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030109

Another problem with DIVS, I suppose; but this time the page also crashed.

Reproducible: Always

Steps to Reproduce:
Open 
http://www.tmb.net/on_soc/present.jsp?dir=MAPA*92-66*1*92-68*Cap*paradas*ESPANYA,267,118,92-66*IE*cat&idioma=cat
or any other map (you can move around Barcelona's map with the arrows at the sides)
Actual Results:  
The image of the map itself is displaced to the right.


Also, I opened it in Composer to check the code again (I had opened it several
times before), but it crashed. TB15990087X

Comment 1

15 years ago
The source of trouble is bit hard to describe. There is a table 2 rows, 3
columns. and map is located inside middle column, second row. 

This map is entered by:

<div style="position:relative; left:0px; top:2px;">
   <img src=../../img/maps/zoom1/102692-68.gif width="575" height="378" alt=""
border="0">
<div style="position:absolute; visibility: hidden">
  <img SRC="/img/flecha4.gif" alt="" border="1">
</div></div>

So <td> for this cell could not be produced from map, but should be obtain from
table propereties. And first row of this table have no width propereties, so it
seems, that all columns have the same width.

Comment 2

15 years ago
Created attachment 111099 [details]
div inside div and table layer collision.
Ruslan, could you explain what the expected rendering of the testcase you posted is?

Comment 4

15 years ago
Hard to say. I think that author think, that <TD> with <image> inside <div>
should obtain his size from image. Because <img> is replaced element, so size of
<div><img></div> obtained frim <img>. If there is no <div
style="position:absolute"> inside first div, this table formating without
overflow, let me show it.

I not sure, that it is incorrect current behaviour. 

Comment 5

15 years ago
Created attachment 111135 [details]
reduced testcase

with linux trunk 20030109:
on initial or shift-reload, the page is initially ok, but when the size of the
second image is known (hidden in the original URL), the two images shift over
to the right.  reload fixes it (images shift back to the left, inside the
table)

Comment 6

15 years ago
Created attachment 111136 [details]
Expected td, div and img behaviour

Comment 7

15 years ago
So in structure, such as 

<td>
  <div style="position:relative"><img><div></div></div>
</td>

Size of TD calculated as intricint size of image, but for


<td>
  <div style="position:relative"><img><div style="position:absolute"></div></div>
</td>

size of <td> become independent of image size.

Comment 8

15 years ago
regression between linux trunk builds 2002092221 and 2002092408, implicating bug
75121
Keywords: regression, testcase

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 9

11 years ago
Created attachment 246607 [details]
Testcase #4
The URL is 404. The testcases works for me in Firefox 2 and Minefield
on Linux.  Can anyone still reproduce this bug?
Whiteboard: [WORKSFORME?]

Comment 11

11 years ago
worksforme since Mozilla 1.6
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.