Closed Bug 1884094 Opened 5 months ago Closed 4 months ago

Bookmarks, Tabs and History suggestions are not displayed in Address Bar if user has a clipboard entry saved

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 125
Desktop
All
defect

Tracking

()

VERIFIED FIXED
126 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox123 --- wontfix
firefox124 --- wontfix
firefox125 --- verified
firefox126 --- verified

People

(Reporter: vlucaci, Assigned: klubana)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [sng-scrubbed][search-regression])

Attachments

(2 files)

Found in

  • 125.0a1 (20240306211627)

Affected versions

  • 125.0a1 (20240306211627)

Tested platforms

  • Affected platforms: macOS 14.3 , Windows 11 , Ubuntu 22

Preconditions

  • Use a profile that has bookmarks, multiple opened tabs and some history entries.

Steps to reproduce

  1. Launch FF.
  2. Have a link copied to clipboard.
  3. Click on the address bar in NTP.
  4. Select either Bookmarks(*), Tabs(%) or History(^).

Expected result

  • Each selection made by the user returns results in the Address Bar.

Actual result

  • No entries are displayed inside the address bar.

Regression range

  • Not a regression, went as far back as 119.0a1(20230904153932) and the issue reproduces with the same steps.

Additional notes

  • Video attachment of the issue can be found here .
  • The issue can be bypassed if the user presses Space or defocuses/refocuses the Address Bar.
Severity: S2 → S3
Summary: Tabs and History suggestions are not displayed in Address Bar if user has a clipboard entry saved → Bookmarks, Tabs and History suggestions are not displayed in Address Bar if user has a clipboard entry saved

This may be a regression from when we introduced the Clipboard Provider, that has an higher priority (1) than the other (e.g. Places) providers, so the only provider running is the clipboard one.
We could use queryContext to check if we're in search mode and then return the default priority.

Keywords: regression
Priority: -- → P3
Regressed by: 1842230
Whiteboard: [sng-scrubbed][search-regression]

Set release status flags based on info from the regressing bug 1842230

:klubana, since you are the author of the regressor, bug 1842230, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(klubana)
Assignee: nobody → klubana
Status: NEW → ASSIGNED
Attachment #9390611 - Attachment description: Bug 1884094 - Bookmarks, Tabs and History suggestions are not displayed in Address Bar if user has a clipboard entry saved. r=mak → Bug 1884094 - Bookmarks, Tabs and History suggestions are displayed in Address Bar if user has a clipboard entry saved. r=mak
Pushed by klubana@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2690f1d4dfbd
Bookmarks, Tabs and History suggestions are displayed in Address Bar if user has a clipboard entry saved. r=mak
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Flags: needinfo?(klubana)

The patch landed in nightly and beta is affected.
:klubana, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox125 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(klubana)

Fixed clipboard provider to stop running when address bar is in search mode.
This allows the Bookmarks, Tabs and History suggestions to be displayed
when in seach mode and a clipboard entry saved.

Original Revision: https://phabricator.services.mozilla.com/D204288

Attachment #9393277 - Flags: approval-mozilla-beta?

Uplift Approval Request

  • Risk associated with taking this patch: low
  • Fix verified in Nightly: no
  • Steps to reproduce for manual QE testing: Steps are in comment 0
  • Needs manual QE test: yes
  • String changes made/needed: No
  • User impact if declined: We are not showing the zero prefix results in search mode when a URI is in the clipboard
  • Is Android affected?: no
  • Code covered by automated testing: yes
  • Explanation of risk level: one line change covered by an automatic test
Flags: qe-verify+
Attachment #9393277 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as fixed using Firefox 125 beta 5 and latest Nightly 126.0a1 across OSs. Bookmarks, Tabs and History search mode suggestions are now displayed when clipboard has an URI.

Status: RESOLVED → VERIFIED
Flags: needinfo?(klubana)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: