Closed Bug 18842 Opened 20 years ago Closed 20 years ago

URL typed in "open web location" cannot be activated by return key.

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 18446

People

(Reporter: mahjongg, Assigned: akkzilla)

Details

after you have entered an URL in the "open web location" input box you cannot
give the "go ahead" bij pressing Enter, only by clicking on the OK <-/ button.
This is strange as it is more natural to press Enter. After all, you have just
used the keyboard to enter the URL. In fact when entering the URL directly into
the navigation toolbar it is the _only_ way (I know of).
Assignee: shuang → german
reassign it to german to check it up ( think the enter key is just not working
proper yet)
Forwarding to don's app team, this should work eventually. Don, don't know
whether this is your's or an Ender problem, pls feel free to assign as needed.
Yes the enter should submit the URL.
Assignee: don → danm
dialogs.  Can't hit enter to activate default button,
danm.  dup?
Assignee: danm → akkana
Event handling.

  Ironically, and it is a little bit that, this is working on this morning's NT build, but not on
any other platform. I haven't done a complete, multi-platform analysis of this problem, but
I do know that the reason it no longer works on unix is because unix/platformDialogOverlay.xul,
rev 1.6, changed the id of the dialog keyset from "keyset" to "unixdialogkeyset". If you really
want to do that, you should also teach the corresponding C code to look for both IDs.
Dialog default keys become operational if you change it back to "keyset".
  Assigning to the person who made that change for further consideration.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Same issue as 18446.  I'll change the name to "keyset" as soon as I can get
permission to check in.

*** This bug has been marked as a duplicate of 18446 ***
Status: RESOLVED → VERIFIED
verifying as duplicate. Keyboard bindings for dialogs needed to be hooked up.
Also a duplicate of bug 17569.
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
setting to an approximate milestone so it can be off of the no TFV list
Target Milestone: --- → M14
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.