Building with gcc 3.x should issue a configure warning about Java incompatibility

RESOLVED WONTFIX

Status

SeaMonkey
Build Config
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Christopher Aillon (sabbatical, not receiving bugmail), Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Since Java will not work with the gcc 3.x compilers due to binary
incompatibility, we should issue a config warning, so that users who do build
our source releases/cvs are informed that java will not work.  Otherwise they
tend to think that Java not working is a Mozilla bug.  Credit to timeless for
suggesting this.
note: Many ppl use GCC3.2 builds from debian, suse or other rpms and they will
not see this warning.
Those distributions include their own warnings.
Remind me to smack timeless.  Should we warn that Irix -n32 builds (the only
ones we support) aren't compatible with Irix NS4.x plugins?  Or that mach-o
builds aren't compatible with cfm plugins?  This seems extremely silly to me. 
The people I see complaining about this problem on irc are the same people who
have to be force-fed the build instructions that are sitting on a webpage.  It's
not worth the effort.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.