Closed Bug 1884571 Opened 2 months ago Closed 2 months ago

WaterfallBackground crashes the netmonitor

Categories

(DevTools :: Netmonitor, defect, P2)

Firefox 123
defect

Tracking

(firefox125 fixed, firefox126 fixed)

RESOLVED FIXED
126 Branch
Tracking Status
firefox125 --- fixed
firefox126 --- fixed

People

(Reporter: kingof25574, Assigned: bomsy)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:123.0) Gecko/20100101 Firefox/123.0

Steps to reproduce:

just watch my sites behavior while fixing backend errors.

Actual results:

[Exception... "Failure" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://devtools/client/netmonitor/src/widgets/WaterfallBackground.js :: draw :: line 136" data: no]

Expected results:

i don't know

Probably hard to reproduce but we had several reports for issues with this component.
This canvas is used to draw lines over the timeline (rightmost part of the request list).

We can quickly add a try catch around the draw method to avoid errors, but we should probably change the implementation to stop generating this huge canvas.
It's not clear if the error is due to a canvas becoming too big, or if we are trying to update a canvas at the wrong time (eg not initialized).

P2 to add a try catch and avoid breaking the panel. We should handle the deeper investigation in a followup.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Depends on: 1484005
Summary: "Failure" nsresult: "0x80004005 (NS_ERROR_FAILURE)" → WaterfallBackground crashes the netmonitor when trying to render
Blocks: 1484005
No longer blocks: netmonitor-timings-sidepanel
No longer depends on: 1484005
Duplicate of this bug: 1885152
Summary: WaterfallBackground crashes the netmonitor when trying to render → WaterfallBackground crashes the netmonitor
Blocks: 1885799
Assignee: nobody → hmanilla
Status: NEW → ASSIGNED
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d951bbae042e
[devtools] Catch and log the waterfall background error to the browser console r=devtools-reviewers,nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch

Comment on attachment 9391673 [details]
Bug 1884571 - [devtools] Catch and log the waterfall background error to the browser console r=#devtools-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Devtools crashes for developers
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just a try catch added stop crashing and instead log the error to the browser console
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9391673 - Flags: approval-mozilla-beta?

Comment on attachment 9391673 [details]
Bug 1884571 - [devtools] Catch and log the waterfall background error to the browser console r=#devtools-reviewers

Approved for 125.0b2.

Attachment #9391673 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1889806
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: