EXDATE field in iCalendar not honoured

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Daniel Patterson, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I've generated a calendar in Ximian Evolution, and added a VEVENT that occurs
once a week (each friday).  Evolution allows you to specify "exceptions" to the
repetition which, from what I can tell, adds "EXDATE" lines to the iCal data.
Here is a sample event:

BEGIN:VEVENT
UID:20021223T072450Z-1379-1000-1-0@chuckles
DTSTAMP:20021223T072450Z
DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/Australia/Melbourne:
 20021226T183000
DTEND;TZID=/softwarestudio.org/Olson_20011030_5/Australia/Melbourne:
 20021226T203000
TRANSP:OPAQUE
SEQUENCE:6
SUMMARY:Swim/Run Session with Tri crew
LOCATION:Port Melbourne
CLASS:PUBLIC
LAST-MODIFIED:20021223T075749Z
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=TH
EXDATE;VALUE=DATE:20030123
EXDATE;VALUE=DATE:20030116
EXDATE;VALUE=DATE:20021226
END:VEVENT

The EXDATE field does not seem to eliminate the specified occurrences from
the Mozilla Calendar display.

Reproducible: Always

Steps to Reproduce:
1. Generate a Calendar file with EXDATE headers
2. Use it in Mozilla Calendar

Actual Results:  
Calendar displayed events that were supposed to be excluded from repetition.

Expected Results:  
Calendar should not have show the repeating event on the dates specified in the
EXDATE field.
(Assignee)

Comment 1

16 years ago
Seems to be a backend issue.
Assignee: mikep → mostafah

Comment 2

16 years ago
The format for their file appears to be different than ours.
Here's my sample file that works (made from Mozilla, so its obviously going to
work):
BEGIN:VEVENT
UID
 :981022553
SUMMARY
 :Weekly Recur
CLASS
 :PRIVATE
X
 ;MEMBER=AlarmEmailAddress
 :mike@inthehack.com
RRULE
 :FREQ=WEEKLY;INTERVAL=1;BYDAY=TH
EXDATE
 :20030123T000000
DTSTART
 :20030116T160000
DTEND
 :20030116T173000
DTSTAMP
 :20030116T205757Z
BEGIN:VALARM
TRIGGER
 ;VALUE=DURATION
 :-PT15M
END:VALARM
END:VEVENT

Note the different formats, they have their dates on one line, we put it on
multiple lines.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 0.9

Comment 3

13 years ago
This format, produced by Apple iCal, is also not recognized by Calendar.

EXDATE;TZID=Canada/Eastern:20050228T144500

Updated

13 years ago
QA Contact: gurganbl → general

Comment 4

12 years ago
The sample event WFM in nightly builds of Sunbird.  I get exceptions on exactly the days specified.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Target Milestone: 0.9 → ---
You need to log in before you can comment on or make changes to this bug.