Browser takes extremely long to load / use in i486 75MHz, 8MB RAM

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Arman Soetanto, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

I tried installing this version of Mozilla (1.1.0.2002072104) to a Win95 OSR2.0
system (haven't applied any patch to the OS, e.g. from windowsupdate.com).
System is a Toshiba Satellite T2115CS notebook, with Intel 486 75MHz processor,
8 MB RAM, 1 MB video RAM, free hardisk space still above 100 MB.
Note: You'll see "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b)
Gecko/20020721" together with this report, that's because now I'm writing this
from my other computer, but using the same Mozilla build.

When I opened/launched the browser, it took more than 5 minutes (maybe 10
minutes) just to finish loading. The computer kept reading/writing files to the
hardisk during that period.
At first, I guess it's because Mozilla use multiple/complex compression
technology, like Netscape does (I think). <But a long time ago, I ran a version
of Netscape (sorry, I forget the version) and it still loaded faster. That was
when Win95 is the highest Win9x version, so I guess it's Netscape 3.x>

Finally, the hardisk lamp stopped "flashing". I tried moving the (mouse) cursor
over, the lamp began flashing again for several seconds. I clicked the menu bar
"File", hardisk indicator lamp flashed for several minutes. I chose exit, and it
took quite long for the lamp to stop, although much faster than when I loaded
the program.

During hardisk access, I can still click Start menu, browse folder, etc. (i.e.
the system doesn't "stop responding"). But the perfomance is severely degradated.

Out of curiousity, I tried restarting Windows, did defragmenter, and restarting
again before opening mozilla.exe. But the problem remained the same. I haven't
tried to re-load the program for a second time within one "session". (means,
open the program, close, and open again without reboot first) Maybe I'll try
doing so today - but won't expect much improvement...
I haven't also tried to monitor CPU usage during that "hardisk-accessing"
period. I'll do that on your request.

My email is monedora@yahoo.com, by the way.

I know 8MB RAM is very little. And the minimum requirement listed is 64MB with
233Mhz processor. But Opera 6 and IE 5 loads much much faster than Mozilla. And
there's no such "slow motion and thinking" (like when I move the mouse) after
it's loaded.

Is it a bug?
If it's not, please consider this as a suggestion / input, as in my Pentium4
system, Mozilla still need longer loading time for the first time after system
boot. I assume this is because Mozilla compress its files, right? With today's
hardisk reasonably cheap,... you can try making a "bloat"ware.

Sorry, I can't help with programming / fixing the bug myself :(
Keep improving!
-- Arman

Reproducible: Always

Steps to Reproduce:
1. install the program on a slow, old system (like i486 CPU with 8MB RAM)
2. run the program
3. see how long it takes to complete
Actual Results:  
The program "run" very slow. (please refer to the Details for the definition of
"run")
Note: I didn't try opening webpages. It just takes long to load, etc.

Expected Results:  
Load faster
Arman, the basic problem is that Mozilla requires a good bit more than 8MB of
RAM to run (about 20 is what we need).  So when running on an 8MB system, over
half the application is constantly swapped out to disk by the operating system.
 Attempting to do anything involves bringing in the code from disk, running it,
then putting it back to disk to make room for other code that it needs to run.

Netscape 3 is a much smaller program, with many fewer capabilities... there is
no way that we can match it for size (and hence for speed on low-end hardware).

IE5 and opera6 are better comparisons (though IE6/Opera7 would be more
comparable)... and yes, we are slightly bigger and slower than they are.  This
is being worked on, but what's helpful there are reports of particular issues at
the code level or particular testcases that we are slow on, or profiles that
show how time is spent.   Something like "slow startup" is far too general (see
bug 7251 for how broad a topic that is.

I'm going to have to mark this bug invalid.  This does not mean that Mozilla is
not slow on your machine, and it does not mean that we don't plan to make it
smaller and faster.  But it does mean that this bug report doesn't really have
any information that would help us get there.

Thank you for taking the time to file a bug, and I hope that if you encounter
any trouble with it on your other computer we will be able to help more
effectively...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
Thanks very much for your explanation and time.

What I can't understand is: why a much bigger & bloat program like IE5 (I 
believe IE6 do, too) can load much much faster than Mozilla (in my old i486 
with only 8MB RAM)??
And I think Mozilla is inefficient in handling processes/user-inputs. For 
example, just hovering onto a menubar (not even clicking on it) requires 
significant hardisk/swapfile access, about 5-10 seconds. Both IE and Opera do 
not experience this problem so badly. Only 1-2 seconds is required. It is such 
a simple process that should not need much data accessing/reloading.

BTW, is there any litte improvement on the latest version/build that may 
address this (my build 1.1.0.2002072104)?? I'm using dial-up so I may consider 
before downloading.

BTW, yes, I want to question another thing. See in my other post (nevertheless, 
I think someone else may have submitted the similar).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Arman, there are two reasons we take up more space than IE5 (or 6): 1) we do a
lot more than those browsers do and 2) We do not share a lot of our code with
windows itself, unlike those browsers, so you end up with effectively both sets
of code loaded.

Hovering a menubar in mozilla has a hover effect that is implemented through the
general layout engine.  Thus to show the hover effect requires the whole layout
engine to be swapped in (and with only 8MB it _will_ be swapped out -- Win95
itself needs 16MB to run; see its minimum system requirements).  Yes, this makes
things painful on hardware such as yours; on hardware that fits the minimum
system requirements it is not a problem; that is why the minimum requirements
are set where they are.

If you need a Gecko-based browser that runs on your hardware, I ould recomend
K-meleon, which uses a different UI.  Mozilla itself is basically _not_ designed
to do so and without a total rewrite of the UI (a la K-meleon) will not run well
on machines with that little ram.

Yes, recent versions are faster than 1.1; though the measurements are all taken
on machines with much more ram than yours (I think 32MB is the lowest we test
on), so I cannot predict how it will perform in your case.  You may want to wait
for 1.3 to ship to test it....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
>> Arman, there are two reasons we take up more space than IE5 (or 6): 1) we do 
a lot more than those browsers do and... <<
IE5 actually takes more (hardisk) space than Mozilla. But Mozilla runs much 
slower, maybe because it takes more RAM space?

>> Hovering a menubar in mozilla has a hover effect that is implemented through 
the general layout engine. <<
Hmm... just wanna say that Opera 6 (which obviously do not share code with 
Windows) doesn't need this much swapping. The "hover effect" you said is 
apparently just a "box" appearing in front of the (menubar) text (i.e. File, 
etc.).

>> If you need a Gecko-based browser that runs on your hardware, I ould recomend
K-meleon, which uses a different UI. <<
Where can I download K-meleon?
What is "UI" (sorry, I don't want to appear dumb but I really not familiar with 
it)?
Does K-meleon support Java as well?? Has it any plug-in (Flash, etc...)?

Thank you ^_^
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
> maybe because it takes more RAM space?

Yes.

> which obviously do not share code with Windows

Sure it does.  It uses the standard Windows widgets (buttons, menus, etc)
instead of implementing its own via its layout engine.

> Where can I download K-meleon?

First hit on k-meleon at http://google.com  ;)

> What is "UI" 

User Interface.

I don't know much about K-meleon, so I cannot answer your questions.

Please do not reopen this bug... As I said in comment 1 it contains nothing
specific that can be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
K-Meleon supports Netscape/Mozilla plugins just fine, including but not limited
to Java and Flash.
(Reporter)

Comment 7

15 years ago
>> Sure it does.  It uses the standard Windows widgets (buttons, menus, etc)
instead of implementing its own via its layout engine. <<
Does K-Meleon implement its own layout? If so, it's likely to be slow, right? 
(I'm gonna try it, anyway)

However, I see that Opera interface is not so similar to that of Windows. And 
Mozilla interface not far different from Opera (both Opera and Mozilla use 
smoother buttons, 3D efffects, etc).


>> Please do not reopen this bug... As I said in comment 1 it contains nothing
specific that can be fixed. <<
My apology. I was thinking that if this bug remained invalid, no one will read 
my comment.

BTW, what is "Assigned To:" and "QA Contact" (do you know what QA is??)?
Sometimes, those 2 fields contain different persons.
> Does K-Meleon implement its own layout?

No.  That's its whole reason for existence.  ;)

> what is "Assigned To:" and "QA Contact"

"Assigned To:" is who the bug is currently assigned to to be dealt with; when
bugs are newly filed they go to default assignees (who are not necessarily
people who fix bugs).  "QA Contact" is the quality assurance person who is
responsible for the bug (eg for verifying that it has been fixed when it's
marked fixed).
(Reporter)

Comment 9

15 years ago
Dear Boris Zbarsky,
I just searhed for "Chimera" at google and got this:
"Chimera is a browser for Mac OS X that has
a Cocoa user interface, and embeds the Gecko layout engine."

What is a layout engine, if it's different from user-interface??
Arman, a layout engine is something that takes things and positions them on the
screen correctly (and paints them, etc).  The Gecko layout engine can lay out
HTML; that's what Chimera is using it for.  It can also lay out an interface
description language called XUL; the Mozilla interface is written in this. So in
Mozilla the layout engine is used for both web pages and the user interface.  In
Chimera, it's used for web pages and the OS-native functions are used for the
user interface.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.