Closed Bug 1884694 Opened 3 months ago Closed 3 months ago

Translations' first pop-up is not triggered while on a reader mode page with a different language than the OS's

Categories

(Fenix :: Translations, defect, P1)

Firefox 125
All
Android

Tracking

(firefox125 wontfix, firefox126 verified)

VERIFIED FIXED
Tracking Status
firefox125 --- wontfix
firefox126 --- verified

People

(Reporter: mlobontiuroman, Assigned: olivia)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxdroid][foundation])

Attachments

(1 file)

Attached video bug.mp4

Prerequisites

  1. Go to the three-dot menu - Settings - About Firefox Nightly, and tap 5 times on the logo.
  2. Exit the About Firefox Nightly, and go to the Secret Settings.
  3. Enable the "Enable Firefox Translations" toggle.
  4. Set your device's OS to English - US.

Steps to reproduce

  1. Go to elpais.com, or wikipedia.ord --> and select Deutsch, or Espanol, or any other language different than English.
  2. Observe if the translations first pop-up is displayed.

Expected behavior

The first translations pop-up is displayed.

Actual behavior

The toolbar has no "translate" icon, and there is no translations pop-up.

Device information

  • Firefox version: Nightly 125.0a1 from 3/11
  • Android devices: Google Pixel 6 (Android 14)

Any additional information?

  • Workaround: tap on the three-dot menu, then on the "Translate page", and the pop-up is displayed, as in the short video attached.

Notes:

  • having a clean profile, and opening wikipedia.org - German, or a different language than en-US, triggers the first pop-up.
  • having a clean profile, and opening elpais.com, does NOT trigger the first pop-up.
Assignee: nobody → ohall
Priority: -- → P1
Whiteboard: [fxdroid][foundation]

Root cause appears to be the engine not deciding on a "to" language as a default. (It'll only offer if it has a best guess for both "from" and "to right now.)

Connecting bug 1847701 as a see also to try and narrow down the issue. (It could impact "to" languages.) It's first version with is 20240311092833.

Tested using a Pixel 4a on both Android 13 and Android 14 on GV: 125.0a1-20240310211048 and a default is available and it pops up as expected using English as a default language.

Curious to see if bug 1847701 had or has an impact on this bug.

Hi Mira,
Do you happen to have the full GV version handy from this test? Trying to see if bug 1847701 was in that version to rule it in or out as a starting point factor.

Flags: needinfo?(mlobontiuroman)
See Also: → 1847701

Fenix Nightly 125.0a1, GV: 125.0a1-20240310211048

Flags: needinfo?(mlobontiuroman)

Investigating more, I have noticed that only on the pages with "reader" mode available I can reproduce this issue.
On yr.no (which is a Norwegian page, no reader mode available) the translation pop-ups are displayed every time, without issues.

Summary: Translations' first pop-up is not triggered while on a page with a different language than the OS's → Translations' first pop-up is not triggered while on a reader mode page with a different language than the OS's

Was able to reproduce today on a Pixel 4a. I think it might have something to do with the App Language not picking up as the "to" language. Will investigate more to understand the scenario better.

See Figma too. (Likely same root issue.)

Hi Mira,

I'm having trouble finding steps to reproduce. I thought I reproduced this the other day on an Android 14 device, but now I'm not quite sure. I tried today on an emulated Pixel 6 running Android 14. Could you help?

In the video, the reason it isn't popping up is that there is no "to" language. I'm trying to eliminate that there are no expected reasons for this to occur.

Could you add to the bug the app language, OS language(s) , and intl.accept_languages languages? (intl.accept_languages can be checked in about:config.)

Expected reasons for missing a "to" language are generally when we expect that the user knows the language. We only show on the toolbar if it is an expected translation. We expect translations on sites in languages the user does not know.

Expected Missing "to" language and no toolbar icon Scenario 1:

  • My App language is in German
  • My OS language has 1. English 2. Spanish set
  • The app will not offer to translate on the toolbar with a default "to" specified on any web pages in German, English, nor Spanish
    • German, English, and Spanish are all presumed "known" languages to the user
  • On a French website, the recommended "to" language will be German (as it is the app language).
  • On a German website, the recommended "to" language will empty
  • On a English website, the recommended "to" language will be empty
  • On a Spanish website, the recommended "to" language will be empty

Expected Missing "to" language and no toolbar icon Scenario 2:

  • My App language is in English, reflecting the OS.
  • My OS language has 1. English 2. Spanish set
  • The app will not offer to translate on the toolbar with a default "to" specified on any of these languages, Spanish nor English
    • English and Spanish are all presumed "known" languages to the user
  • On a French website, the recommended "to" language will be English (as it is the app/OS language).
  • On a English website, the recommended "to" language will be empty
  • On a Spanish website, the recommended "to" language will be empty

A bug scenario can happen if we didn't detect a language in one of these spots or have something faulty going on in these places.

(When making OS/App language changes, please ensure a hard close between changes.)

Flags: needinfo?(mlobontiuroman)

Asked on Bug 265400 for more information to get a sense if the scenario as described in bug 1884694 comment 6 needs to be corrected or if Android has the preferred behavior. (If this same scenario is tested on the Desktop translations feature, then it only picks the first language as a "known" language, since the other preferred languages aren't added to intl.accept_languages.)

See Also: → 265400

Hi Olivia!

I was able to reproduce the bug following these prerequisites:

  1. Enroll in the Nimbus translations experiment.
  2. Clear the profile of Fenix Nightly.
  3. Open the first page elpais.com --> there is no first pop-up.
    (Opening wikipedia.org - Spanish triggers the first pop-up!)

Tested on today's Nightly 125.0a1 from 3/18 with the following devices:

  • Google Pixel 6 (Android 14) where: the OS had the en-US as default (and es-ES not set as default); Fenix Nightly followed device's language;
  • Oppo Find N2 Flip (Android 14) where: the OS had only the en-US; Fenix Nightly followed device's language;
  • Xiaomi mi8 Lite (Android 10) where the OS had the en-US set as default (and all the available languages displayed in a list); Fenix Nightly followed the device's language.

Please let me know if there is anything needed to verify.

Flags: needinfo?(mlobontiuroman)

Thanks so much for the additional details!

I think I need just a few more details to figure the rest out!

  • Can you go to about:config and check what is the string under intl.accept_languages for these devices?
  • Is the toolbar icon showing up in all of those cases?
Flags: needinfo?(mlobontiuroman)

Oh, sorry, I forgot about that:

  • Google Pixel 6 (Android 14): intl.accept_languages displays en-US,es-ES - no icon displayed,
  • Oppo Find N2 Flip (Android 14): intl.accept_languages displays en-US - no icon displayed,
  • Xiaomi mi8 Lite (Android 10): intl.accept_languages displays en-US - no icon displayed.
Flags: needinfo?(mlobontiuroman)
Flags: qe-verify+

(Likely will be fixed by Bug 1884445.)

Verified as fixed on the latest Fenix Nightly 126.0a1 from 4/4, with Google Pixel 6 (Android 14), Realme C35 (Android 12), and Samsung Galaxy Note 8 (Android 9).
When opening an eligible translatable reader mode page, the translation bottom sheet is triggered, without issues.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: