Shift-clicking to download a file should make a dialog appear immediately

RESOLVED DUPLICATE of bug 133732

Status

SeaMonkey
UI Design
--
minor
RESOLVED DUPLICATE of bug 133732
15 years ago
9 years ago

People

(Reporter: Vincent Lefevre, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3b) Gecko/20021226
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3b) Gecko/20021226

When I shift-click on a file to download it and there is a problem with the
server, nothing happens immediately, but I get the following error after a
timeout (about 20 seconds?): "The link could not be saved. The web page might
have been removed or had its name changed."

Reproducible: Always

Steps to Reproduce:
1. Shift-click on a link to download the file after making sure that the file
can't be downloaded (I no longer have a URL showing the problem).
Actual Results:  
Nothing happens immediately (from the user point of view).

Expected Results:  
A dialog should have appeared or something else showing that the event was taken
into account.

*** This bug has been marked as a duplicate of 133732 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.