Mozilla crashes when using the back button after downloading playing wav file from Yahoo groups with Quicktime plug-in

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: raymond.l.wilshire, Assigned: peterlubczynski-bugs)

Tracking

({crash, stackwanted})

Trunk
x86
Windows NT
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030110
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030110

I have had this problem with every case of downloading attachments from any of
the yahoo groups I belong to.

I went to the following URL 
http://groups.yahoo.com/group/wavsongs/message/5688

I right-clicked on the Download link and selected Save Link Target As..
the download manager window did not open. 
I got a dialog box that said:

The link could not be saved. The web page might have been removed or had its
name changed.

The URL of the link was:
http://attach2.groups.yahoo.com/v1/MBgfPvy5rKPt9RwmNPq6s3unUECNoa3ZVdQfjtxnIpww9ORaZjq9w9gNcIpfoaPo83xnJ2hRZyqyOlY1I5NrDUlu5j5BViYmlmv81A/02-Anita%20Baker%20-%20You%20Bring%20Me%20Joy.wav
Apparently Yahoo generates a new link everytime you reload the message page and
after some unspecified time(5-10 min) disables the link and requires you to
reload the page and get a new link. I did and got this link.
http://attach2.groups.yahoo.com/v1/UDQfPjgQIbFiSi5fL9BIwYGfedBZhRFXV2nvmROo0kkiMVJ_YtE3GBtM-csorSiLSqEXs3qWk31DzqS9ML_8mPfSspgmPfCfMr0HxA/02-Anita%20Baker%20-%20You%20Bring%20Me%20Joy.wav


When I left-clicked on the link the browser it used the QT Plugin Version 4.1.2
to download and play the wav file. 
This worked fine but when I clicked on the back button the window crashed and
opened a Netscape talkback window 
and a Dr Watson window which said:
 
Dr. Watson for Windows NT

An application error has occurred
and an application error log is being generated.

mozilla.exe
Exception: access violation (0xc0000005), Address: 0x66c68c72



Reproducible: Always

Steps to Reproduce:
1.Open a message in Yahoo Groups that has an attachment
2 [review].Left-click on the download link 
3.Click the back button

Actual Results:  
Mozilla crashes

Expected Results:  
returned to the previous page

I don't know how it applies but could this be related to either the length of
the URL of the download link or the fact that it is generated per incident
causes it to lose track of where it came from?
(Reporter)

Comment 1

16 years ago
Created attachment 111229 [details]
Dr Watson error log associated with this crash

Comment 2

16 years ago
can you post Talkback ID for this crash "mozilla/bin/components/talkback.exe" ?
Keywords: crash, stackwanted
Summary: Mozilla crashes when using the back button after downloading playing wav file from Yahoo groups with Quicktime plug-in → Mozilla crashes when using the back button after downloading playing wav file from Yahoo groups with Quicktime plug-in

Comment 3

16 years ago
-> download manager.

You should also file the left-click -> back button bug in History:Session and
put the talkback number there.
Component: Networking → Download Manager
(Assignee)

Comment 4

16 years ago
-->plugins

Please verify this bug exists in a daily Mozilla trunk talkback-enabled build
with the latest version of Quicktime (6) from Apple. Quickime 4 is very old and
has known issues with Gecko. If you do crash, please note the Talkback ID in
this bug report.
Assignee: dougt → peterlubczynski
Component: Download Manager → Plug-ins
QA Contact: benc → shrir

Comment 5

15 years ago
Well acording to yahoo there is no group with the name wavsongs, close this bug
out because there is no testcase?

Comment 6

15 years ago
Marking WFM.
Ray, please reopen if still crashing with Quicktime 6.5 and Mozilla 1.7b or
later. Make sure to mention Talkback ID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.