Streaming quicktime movie is garbled with two QT instances open

RESOLVED WONTFIX

Status

()

Core
Plug-ins
P3
normal
RESOLVED WONTFIX
15 years ago
11 months ago

People

(Reporter: John Silver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

Also see sound probs with other videos from same streaming site. Works correctly
in IE and Safari.

Reproducible: Always

Steps to Reproduce:
1.Go to URL above
2. Play first movie, until person starts talking
3. Observe visual defects in embedded QT window

Actual Results:  
Defects in QT image as described above.

Expected Results:  
Display QT image correctly.

We use this site on a LAN, but you should be able to use the movie from a remote
high bandwidth site; we have users who do.

Comment 1

15 years ago
Hmm.. I'm having no luck getting the qt stream to load so I can actually see the
problem described. The QT plugin shows the QT animation but never displays the
video content. Any chance we could get another url to test ?

Comment 2

15 years ago
Ok, the QT stream appears to be working now. I can see a noticeable amount of
noise and artifacts appearing in the video. I don't see this same issue in the
Mozilla CFM trunk (2003-01-03-08) NB, Safari beta, or IE 5.2.2. I have QT 6.1
installed under 10.2.3.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Definately worse in camino than safari.
Assignee: peterlubczynski-bugs → pinkerton
Priority: -- → P3
QA Contact: chrispetersen
Summary: Display in embedded quicktime window at above URL is garbled. → Streaming quicktime movie is garbled.
Target Milestone: --- → Camino1.1
The garbling seems to happen when two or more instances of QT are open anywhere in Camino, where one is streaming.

Simon, this seems like a perfect bug for you. ;)
QA Contact: plugins
Summary: Streaming quicktime movie is garbled. → Streaming quicktime movie is garbled with two QT instances open
Assignee: mikepinkerton → nobody
Target Milestone: Camino1.1 → Camino2.0

Updated

11 years ago
Duplicate of this bug: 389066

Updated

10 years ago
Target Milestone: Camino2.0 → ---

Comment 6

10 years ago
We've duplicated this bug on a Mac with QT 7.4.5 and QT 7.5.  Confirmed that it used to work with Firefox 2 (on the same machine).  We have NOT duplicated it on any Windows box (where it seems to work).

Another test URL is:
http://ccnmtl.columbia.edu/~sky/bugs/safari/autohref/
(see first row's video)

It seems to fix itself at the keyframes, so the streaming diffs between them have offset problems or something. (that's a wild observation unconnected to any knowledge of how the code or plugin works in depth)

Comment 7

10 years ago
I realize I've co-opted an old bug.  It is the same issue :-)

It's visible on Firefox 3.1a2 (nightly trunk)
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/2008072402 Minefield/3.1a2pre

and Firefox 3.001
Moving this to Core:Plug-ins based on comment 6 and 7; any time you have two QT instances on a single page, all of them will display garbled video from the get-go.
Component: Plug-ins → Plug-ins
Product: Camino → Core
QA Contact: plugins → plugins
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.