Two first chars of files chopped

RESOLVED DUPLICATE of bug 136831

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 136831
15 years ago
13 years ago

People

(Reporter: Philip Nilsson, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

I think this bug fits better in General as it hasn't reallt anthing to do with
the download manager, this bug appears before the download manager is launched(I
think).
The bug is that the first two characters of filenames are stipped from files you
download from http://www.fileplanet.com/, the stipping first occurs when you the
download file dialog pops up.
I'm including a link with a file that should reproduce the bug:
http://xferva1a.fileplanet.com/^514195508/ftp2/planetfortress/hlmp/skillout-cgq.zip
The file lies in a temporary directory, so I'm not too sure of how long it will
be before it is removed, and I do not know if this bypasses registration(which
doesn't confer any spam :))
Fileplanet is the only place that I've encountered this at, I've only been using
mozilla for 3 days or so though. 
My guess at what's causing it is the ^ in the url, maybe it screws some filename
parsing function up or so... I haven't looked at the source, but that's your task :p

Reproducible: Always

Steps to Reproduce:
1. Find a file @ fileplanet.com
2. Download file
3. Be unhappy

Actual Results:  
I became unhappy == the two first characters were removed and I had to add them
manually.

Expected Results:  
o_O? No idea, not remove them :)?

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 136831 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.