for xul:textbox; CSS's property "text-align" does nothing;

RESOLVED FIXED in mozilla1.5alpha

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Ariel Fatecha, Assigned: Ariel Fatecha)

Tracking

Trunk
mozilla1.5alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

525 bytes, application/vnd.mozilla.xul+xml
Details
273 bytes, text/plain
Details
971 bytes, patch
jag (Peter Annema)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

if you have a xul:textbox and a sytlesheet with a property:
"text-align: right;" nothing happens, because html:input doesn't have:
"text-align: inherit;"

Reproducible: Always

Steps to Reproduce:
1. in XUL: <textbox class="mytxt" value="hi,man"/>
2. in CSS: .mytxt { text-align: right;}
3. Nothing happens.
Actual Results:  
text is left aligned yet.

Expected Results:  
in all textbox.css (modern and classic) add a single line:
  text-align: inherit;
into:
  html|textbox-input,
  html|textbox-textarea{
    ...
    text-align: inherit; /* new line */
  }
(Assignee)

Comment 1

16 years ago
Created attachment 113678 [details]
testcase

this file has a textbox and a button, button change an attribute into the
textbox.
it's all.
the problem is in css.
need bug188597.css.
(Assignee)

Comment 2

16 years ago
Created attachment 113679 [details]
testcase

this file need bug188597.xul
contain the real problem.
Solution required add one line in every textbox.css
html|input{
  ... 
  text-align: inherit; //added
}
Yeah, adding that to either textbox.css or just as an inline style rule in the
XBL binding would make sense.... (I almost favor the latter over the former
since then theme authors don't have to deal with this....)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
*** Bug 81060 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Couldn't we put that in xul.css, or a toolkit/global textbox.css?
Yeah, that would be better than inline style.  ;) Either of those is good with me.
(Assignee)

Comment 7

16 years ago
isn't closed?, ok, I'll post the proposed patch, inserting line in xul.css, like
said jag(Peter Annema)
(Assignee)

Comment 8

16 years ago
Created attachment 114093 [details] [diff] [review]
patching xul.css

adding: text-align: inherit;
(Assignee)

Updated

16 years ago
Attachment #114093 - Flags: superreview?(bzbarsky)
Attachment #114093 - Flags: review?(jaggernaut)
Comment on attachment 114093 [details] [diff] [review]
patching xul.css

As the file says, one of the reviewers needs to be hyatt (@apple.com, not
@netscape.com).  Pleaes mail him personally; he does not read bugmail.
Attachment #114093 - Flags: superreview?(bzbarsky) → superreview?(hyatt)

Comment 10

16 years ago
Comment on attachment 114093 [details] [diff] [review]
patching xul.css

r=jag. Looks good to me. hyatt?
Attachment #114093 - Flags: review?(jaggernaut) → review+
(Assignee)

Comment 11

16 years ago
hyatt is busy
Assignee: hyatt → afatecha
(Assignee)

Updated

16 years ago
Attachment #114093 - Flags: superreview?(hyatt) → superreview?(ben)
(Assignee)

Updated

15 years ago
Attachment #114093 - Flags: superreview?(ben) → superreview?(hewitt)
(Assignee)

Updated

15 years ago
Priority: -- → P3
Whiteboard: [patch, super-review]
Target Milestone: --- → mozilla1.5alpha
(Assignee)

Updated

15 years ago
Attachment #114093 - Flags: superreview?(hewitt) → superreview?(jst)
Comment on attachment 114093 [details] [diff] [review]
patching xul.css

sr=jst
Attachment #114093 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 13

15 years ago
patch is r+ and sr+.
Questions:
what now?
can I check it into the tree? 
change resolution to "fixed"?
Whiteboard: [patch, super-review]
If you want it for 1.4b or 1.4, you need to request a= (see the options when you
edit the attachment).  If for 1.5a, ask someone to check it in for you once the
tree reopens.
(Assignee)

Comment 15

15 years ago
Comment on attachment 114093 [details] [diff] [review]
patching xul.css

thanks :)
Attachment #114093 - Flags: approval1.4b?
Attachment #114093 - Flags: approval1.4b? → approval1.4b+
(Assignee)

Comment 16

15 years ago
ok, patch has approval1.4b+
sorry, but more questions:
change resolution to "fixed"?
when is the patch inserted into the tree?
When someone checks it in.  I'll try to do that tonight.
Checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

15 years ago
thanks... :)

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.