Valid HTML 3.2 documents parsed as quirks

RESOLVED INVALID

Status

()

Core
Layout
--
minor
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Mathew McBride, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030110 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030110 Phoenix/0.5

In a valid HTML 3.2 page, Mozilla/NGLayout(/Gecko) reports valid HTML 3.2 as
being processed in the Quirks render mode

Reproducible: Always

Steps to Reproduce:
1. Go to a Valid HTML 3.2 page (the HTML 3.2 Reference Specification is a good
example)
2. Right Click on the document and choose properties

Actual Results:  
Properties reported the valid HTML 3.2 page using the Quirks render mode

Expected Results:  
Since the document was valid HTML 3.2, the page should of been processed as
Standards Compliance Mode
Since HTML 3.2 predates the standards that we are attempting to support (CSS and
HTML4, to be exact), we should _not_ be rendering HTML 3.2 documents in
standards mode (since they will break unless the author is posessed of a great
deal of prescience).  The point of quirks mode is to deal with pages written
before the current standards existed; doctype sniffing is just an attempt to
estimate the time when the page was written (this is why HTML 4.01 and HTML 4.0
are treated a little differently).

See http://www.mozilla.org/docs/web-developer/quirks/doctypes.html for more
information on the topic.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.