a list of links scrolls up by itself when I click a link in it

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Minko Markov, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030110
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030110

When I select "view by page" on the left at
  http://www.newriders.com/books/opl/ebooks/0735710430.html
I get a very long list of links. Each is a link to a page
in the e-book. Being several hundred items long,
the list does not fit in the window and one has to navigate
with the scrollbar or the wheel of the mouse. If I scroll
down and click on a link that was not seen before scrolling,
the desired page from the book is displayed in the frame
on the right. However, the list with page numbers "jumps"
to the top by itself.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.newriders.com/books/opl/ebooks/0735710430.html
2. Select "view by page". The list of pages shows up. It is too
   long to fit in the window and there is a scrollbar. I see
   the links to pages 1--15.
3. Using either the scrollbar or the mouse wheel, scroll down
   to any page number that was not seen originally. Say, to
   page 199. Click on it.
Actual Results:  
Page 199 is displayed on the right, but before that
the list on the left scrolls up by itself. Thus,
I see the links to pages 1--15 again.

Expected Results:  
The list should not have moved. If I want to go to
page 200 afterwards using the list of links, I have
to scroll down again.

The list is in a separate frame from the contents of the book.
Netscape 4.77 shows thick grey border between the 4 frames,
Mozilla does not do that. I don't know which of these is correct.

This bug may or may not be related to bug
  http://bugzilla.mozilla.org/show_bug.cgi?id=188613
which is about the same page.
The site has:

<a href="#" onclick="doSomething(); return false;">

on those links.  Problem is, doSomething() throws an exception, the event is not
canceled, and we follow the link to '#', which means top of document.

The reason the exception is thrown is that the script is trying to access
document.next and since it's being called from a _different_ document, it's
looking in the wrong document....

This looks like a bug in the page to me.
Not a Mozilla bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.