Table moves when page is reloaded

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Aaron Leventhal, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
Go to http://www.jsonline.com/sports/buck/
Notice the positioning of the sidebar "Bucks, NBA Game Tracker"

Click on the "Go to Story" link, and then hit Alt+Left arrow to go back in
histroy when that page loads.
Notice the new positioning of the sidebar, it's different now.
(Reporter)

Comment 1

15 years ago
More info:
1. I am using January 6, 2003's build
2. Sometimes reload helps, sometimes it doesn't
3. Clicking on a link outside the site and coming back doesn't seem to create
the problem. You have to click on one of the Bucks story links and then come
back to see the problem. Even then it doesn't always seem to happen on every
link. Perhaps it depends on the positioning of the "Game tracker" sidebar in the
new page.
4. Turning of the memory and disk cache doesn't help fix the problem
(Reporter)

Comment 2

15 years ago
Bernd on IRC said he saw the problem too.
(Reporter)

Comment 3

15 years ago
Also note, sometimes force-reload fixes the page, sometimes it doesn't
(Reporter)

Comment 4

15 years ago
It looks like the sidebar is a table, nested inside another table.
Assignee: asa → table
Component: Browser-General → Layout: Tables
QA Contact: asa → amar
(Reporter)

Comment 5

15 years ago
Created attachment 111275 [details]
One kind of corruption, sidebar overwrites other content
(Reporter)

Comment 6

15 years ago
Created attachment 111276 [details]
Screenshot #2. Another type of corruption, with sidebar above rest of page content
(Reporter)

Comment 7

15 years ago
Aha, I've found that just reloading the page can make that sidebar move around.
Summary: Click on link, go back to page. It looks different now. → Table moves when page is reloaded

Comment 8

15 years ago
Created attachment 111307 [details]
testcase

reproduced with linux trunk build 20030111.  images from the URL are <div>s.

the table with the green <div> extends into the second column of the parent
table.

Updated

15 years ago
Keywords: testcase
OS: Windows 2000 → All
But isn't the original bug report an incremental reflow bug, where a page
displays differently when loaded originally?

We have some quirks for placement of tables near floats.  This testcase might
just be demonstrating one, although I'm not sure.

Comment 10

15 years ago
indeed.  with the URL, changing font size fixes layout (reloading the page never
fixed it for me), but that doesn't work with the testcase.  I made the testcase
based on the initial layout.

I'll see if I can come up with a testcase that also exhibits the incremental
reflow problem.

Comment 11

15 years ago
Created attachment 111313 [details]
testcase with reflow problem

this is similar to the first testcase but fixes itself if you increase font
size and stays fixed even if you then decrease the font size back to normal. 
However, if you then decrease it again, the bug shows up again and stays even
if you increase font size back to normal.

Comment 12

15 years ago
Comment on attachment 111313 [details]
testcase with reflow problem

wrong testcase, argh
Attachment #111313 - Attachment is obsolete: true

Comment 13

15 years ago
Created attachment 111315 [details]
testcase with a reflow problem

the real thing

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Updated

15 years ago
Blocks: 200047

Comment 14

9 years ago
this looks like wfm to me, please reopen but describe what the problem is in attachment 111315 [details], which we render like webkit and opera
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.