[PP] Mac crashes on attached email crashes MIME on display

VERIFIED FIXED in M12

Status

MailNews Core
MIME
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: rhp (gone))

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Build Date & Platform Bug Found:
 MacOS commercial seamonkey build 1999-11-11-11-m11 installed on G3/400 OS 8.6

Overview Description:
 Messenger crashes when trying to display attached email.  The messenger does
not display the message when selected.  I crash to Macsbug when trying to view
the message under an IMAP folder or Local folder.

I will attach mail message after I post this bug.

Steps to Reproduce:
1) Download the message attached to this bug.
2) Copy it to your existing profile local folder or pop profile
3) Launch Messenger
4) Select the mail folder that contains the problem message
5) Select the message
   The message does not display the message in the message pane.
6) Try to select another message or re-size the window
   Crash to Macsbug.

Actual Results:
The message does not display.  The message pane remains blank.  If I try to
display a different message or resize the messenger window, I crash.

Expected Results:
The application should display the message.

Additional Builds and Platforms Tested On:
This problem does not occur on commercial build of win32 1999-11-10-17-m11 and
Linux 1999-11-10-17-m11.

Additional Information:
This bug found when verifying bug 16786 "[DOGFOOD] Attached email crashes MIME
on display"
This Mac m11 build was the latest as of monday morning.

Updated

19 years ago
QA Contact: lchiang → pmock
(Reporter)

Comment 1

19 years ago
Created attachment 2872 [details]
Message that crashes Messenger - same message as in bug 16786
(Reporter)

Comment 2

19 years ago
Created attachment 2873 [details]
MacsBug stdlog
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 3

19 years ago
Hmm...funny. I fixed a bug with this same message on Win32. I will have to
dig into it.

- rhp
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
All old PR IO stuff is now gone from libmime...and this no longer crashes.

- rhp
(Reporter)

Comment 5

19 years ago
Created attachment 3649 [details]
Correct test file.  Dis-regard my previous one.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Verified as fixed using the following builds:
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-12-07-16-M12/netscape5-mac-M12.sea.bin
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.