The vertical scrollbar is one-pixel too rightward (bug #52888 should be reversed)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: jiang_wq, Assigned: shliang)

Tracking

({platform-parity})

Trunk
x86
Windows 98
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030110
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030110

In the classice theme the virtical scrollbar cuts
into the right border, and looks higher than the
window frame (in Z-order).  That's the result of
a fix for bug #52888.  The argument for the fix
in that bug should be unattainable, its cost is
high and the gain is at best arguable.

Both the vertical and horizontal bar should be
positioned in the same plane as the window frame.
(why do people like flat panel displays better?)


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The argument in that bug is very simple. Having the scrollbar at the right edge
of the window makes the scrollbar easier to use.  Many other apps do the same
thing...

Which part of that is wrong?
(Reporter)

Comment 2

16 years ago
The gain:
the scroll bar "easier to use" when the window is maximized.
You can drag your mouse to the right most position and
can still control the bar.  (correct me if I understand
wrongly).  Most windows app don't have that, and the majority
of the users seems OK with that.  (IE is the case.)

The cost:
the UI looks strange: the bar is higer then the window frame.

Sorry if you feel hurt that the fix is "wrong".  If the bar
can riside in the same plane as the frame, and retain the
'fix' when the window maximized, that would be perfect.
Otherwise in my personal opinion I'd prefer the case in IE.
This seems to be a windows-only bug, since I have no "window frame" over here on
linux.  Please make sure not to break this on other platforms if you decide to
mess with it... ;)
Keywords: pp

Comment 4

16 years ago
"Most windows app don't have that, and the majority of the users seems OK with
that.  (IE is the case.)"

The majority of users seems OK with it because they don't have a clue that it
could be different. However, this improvement is very noticeable once you've
used Mozilla for a while.

Recommend WONTFIX.
(Reporter)

Comment 5

16 years ago
The benefit is only when the window is maximized.  If the vertical
scrollbar can be put in the same plane as the window frame, while
keeps in its 'fixed' place when maximized (now no window frame border
exists), isn't that better?

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.