Open Bug 1888385 Opened 3 months ago Updated 7 days ago

[linux] drag tab stops working

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 126
defect

Tracking

()

REOPENED

People

(Reporter: zlice555, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:126.0) Gecko/20100101 Firefox/126.0

Steps to reproduce:

drag a tab in or out of a window

Actual results:

after that tab is dropped, drag-n-drop for tabs quits working

Expected results:

keeps working

The Bugbug bot thinks this bug should belong to the 'Firefox::Tabbed Browser' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Tabbed Browser

Is this on Wayland or on Xorg? Which window manager is used?

xorg, fluxbox. i could test on something else but this same bug has happened before.

looks like firefox nightly must have just updated, working now. feel free to close

cancel that, it would appear it quits working randomly. tabs won't drag again.

mozregression doesnt seem to be pullling all builds, and this is hard to reproduce anyway. expected a '[linux]' commit from stansky and emillio. see some from the past couple days for linux and gdk, a couple that add mutexes. fwiw i have nglayout.enable_drag_images false

It seems possible that bug 1875031 fixed this; would you mind checking again in the latest nightly build?

Component: Tabbed Browser → Widget: Gtk
Product: Firefox → Core
See Also: → 1875031

could be. it's hard to make it happen and seems semi-random. once it's locked it's locked so i'll notice it in a weekish if it's still an issue. fwiw havent seen it in the past couple days

i guess i haven't really seen this, so it either is fixed or very rare. feel free to close.

started happening today. so i guess this is still a problem.

Okay, Thanks.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME

i don't know if you saw the second comment. it's still happening

I see, Thanks.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Also experiencing this on i3.

Hello! I have tried to reproduce the issue with firefox 126.0a1(2024-04-08) on Ubuntu 22.04, unfortunately I wasn't able to reproduce the issue on my end.
Could you please answer the following questions in order to further investigate this issue:

  1. Does this issue happen with a new profile? Here is a link on how to create one: https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles
  2. Does this issue happen in the latest nightly? Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/
  3. Do you have any addons installed? If yes could you please list them?
Flags: needinfo?(zlice555)

My profile was rebuilt right before this started happening. I am on nightly.

ublock and vimium which do not affect the tabs afaik.

There is no easy way to reproduce this, it happened to me last night while searching and opening multiple windows and tabs. The best I have to go off of are the commits around the March 27th when I noticed this happening. Some of the [Linux] commits seemed possibly related iirc

https://hg.mozilla.org/mozilla-central/pushloghtml/5

https://hg.mozilla.org/mozilla-central/rev/79a66bf59a9a6178f8cd43b5f891e4426a4f1fc8

https://hg.mozilla.org/mozilla-central/rev/ba04f6471cad4872240f3bf48621194de6af51f6

https://hg.mozilla.org/mozilla-central/rev/21247c16b00c4e58439eda945000b0964cf2278f

https://hg.mozilla.org/mozilla-central/rev/2d8b8f4a61885b098380625bfe858299c6554a54

https://hg.mozilla.org/mozilla-central/rev/5b7014434f4e2fd550850fc7295b4e471e51551b

Flags: needinfo?(zlice555)

Please try to capture broken scenario and attach log from it. Run Firefox on terminal as:

MOZ_LOG="WidgetDrag:5" firefox > log.txt 2>&1

and if you reproduce it attach log.txt here.
Thanks.

Flags: needinfo?(zlice555)

will do

nothing today. but i did find something else that's a 'bug'. ctrl+t for new tab and click/drag at the same time and youre dragging 2 tabs?

I too have encountered the bug a couple of times (X11/KWin); no STR. I will capture a log next time. Hopefully, doing it via about:logging after the issue manifests would be enough, since its size would be in the hundreds of GBs otherwise.

I, also, have an issue that started happening at the same timeframe (no STR either) and I suspect it is related to this. Sometimes the keyboard input remains "fixed" in a window. For example, I have two windows open and the caret is focused on the urlbar of the first window. When I try to select the urlbar of the second window and type in, the text is inserted in the urlbar of the first window instead. This is temporarily fixed by opening and closing a new window, but only truly resolved by restarting the browser. Is there any log I could capture for this?

Btw, the last buildids I encountered those issues were: 20240414212202 (this bug), and 20240414091434 (keyboard input issue).

So I've had this happen but updating nightly restarts firefox and detaches from terminal.

Apparently, opening a new window fixed dragging?

Is there a better way to capture something when dragging does quit working?

Maybe I'll have to do the debug log and then automate new windows and dragging...

(In reply to zlice from comment #22)

So I've had this happen but updating nightly restarts firefox and detaches from terminal.

Please try again. It updates once per day, so next time it should stay on terminal and produce the log.

not sure if this helps. looks like mostly the same thing over and over agan

Flags: needinfo?(zlice555)
Attached file fflog-trim.txt

fwiw - since i stopped running with the debug option, this issue seems to happen way more often

noticed this can actually stop all drag-n-drop, images and text wouldn't drag today

Please test when Bug 1881229 hits Nightly. I'll look at it you see see it after it.

I think those commits went in? I haven't noticed anything yet but freezing is random so I'll try to open and drag a bunch of tabs tonight or something.

It does seem that I cannot drag and drop pictures to google image search (or anywhere).

Or even a blank page. Which should open a file if you drag and drop to it.

Well, it seems the image thing makes tab dragging break. At least it's reproducible =/

(In reply to zlice from comment #32)

Well, it seems the image thing makes tab dragging break. At least it's reproducible =/

Okay, will look at it. Please provide reproduction steps.
Thanks.

Flags: needinfo?(zlice555)
  • open up a file manager (rox, pcmanfm-qt)
  • drag a picture to a firefox window
  • tab (all?) dragging breaks

fluxbox and openbox

Flags: needinfo?(zlice555)

Please try latest nightly as we landed D210942/D210940 recently:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries
Thanks.

Flags: needinfo?(zlice555)

If you can reproduce it with latest nightly please attach the

MOZ_LOG="WidgetDrag:5" firefox > log.txt 2>&1

log. I updated the logging to get more info.
Thanks.

I'm on MX-Linux running 126.0 (64-bit) and also can't drag tabs, or drag the URL to add it to a bookmark.
Happy to provide any debug logs if that would help.

If you're on nightly and can run with the MOZ_LOG var plz do. The update this morning fixed my reproducible file drag which caused things to break and I'm guessing that means it will be hit or miss if I get it today.

i haven't seen this since the last update. not sure how long it may take to resurface or until it's considered fixed.

still haven't seen this in days/weeks. i guess feel free to close it. not sure if there was another change or the debugging is enough to hide a race condition? thanks stransky

Flags: needinfo?(zlice555)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: