make it easy to run helper app for plugin

RESOLVED DUPLICATE of bug 116027

Status

()

P5
enhancement
RESOLVED DUPLICATE of bug 116027
16 years ago
6 years ago

People

(Reporter: jwz, Assigned: peterlubczynski-bugs)

Tracking

(Blocks: 1 bug)

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Instead of just showing the icon for a missing plugin, it would be really nice
if there was also (or instead?) a link there that simply allowed the plugged-in
URL to be invoked in a helper app.  I have standalone programs that can display
most video formats, but none of them work as plugins.  Yet, all web site
designers assume that plugins work, and don't provide a direct link, so I always
have to go digging it out of View Source.  See also bug 188838.

Really, making it so that clicking on the plugin icon invoked the helper app
would be far more useful than going to the "plugin finder page" or whatever it
does now.
isn't that excatly what plugger does ?
( http://fredrik.hubbe.net/plugger.html )
(Reporter)

Comment 2

16 years ago
Yes, but plugger is halfassed: for example, you have to enumerate *every mime
type* and if you missed one, you have to edit a file and restart Mozilla.

Mozilla should just have this simple "fall back to helper apps" thing built in
as the default "no plugin" behavior.
a helper app and a plugin is a little bit different.
No scripting ...

I don't think we should use a default fallback but we could have an option to
assign one mime-type/extension to a helper app.
Severity: normal → enhancement
(Reporter)

Comment 4

16 years ago
Huh?  All I'm asking for is the insertion of an <A HREF> pointing at the actual
data URL.  I don't see how scripting is relevant to this -- it's not like
scripting works anyway in the case where this matters (the "I don't have a
plugin at all" case!)
I mean this :
Force the user to get the plugin because a few/some/many pages use plugin
scripting. If the user don't want a plugin it should be possible to assign it to
a helper app. (and not by default if there is no plugin)

Marking this as blocking the other bug on this, since comment 4 points out
exactly how this should be done.

Nominating; this would be simple to do and provide a lot of benefit to the user.
Blocks: 116027
Keywords: nsbeta1
(Assignee)

Comment 7

16 years ago
setting fields to match bug 116027
Priority: -- → P5
Target Milestone: --- → Future

Comment 8

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
QA Contact: shrir → plugins

Comment 9

6 years ago
Going to track this in one bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 116027
You need to log in before you can comment on or make changes to this bug.