sncf.com - Javascript error disallows online buys/reservations

VERIFIED DUPLICATE of bug 184274

Status

Tech Evangelism Graveyard
Other
VERIFIED DUPLICATE of bug 184274
16 years ago
3 years ago

People

(Reporter: Benoît Sibaud, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020925 Debian/1.1-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020925 Debian/1.1-1

Error in Javascript blocks buys/reservations, with Mozilla 1.2.1, 1.1. (and the
site can't be visited with Lynx or Konqueror). And, of course (snif), it works
with IE.

Reproducible: Always

Steps to Reproduce:
1) Go to http://voyages.sncf.com
2) For example, ask for a train between Paris and Lyon
You got a list of trains.
3) Pick one of the train. You got the "Commande d'un voyage" page
4) click on validate. Nothing happens due to 

Error: PASSENTR0 is not defined
Source File:
http://www.voyages-sncf.com/dynamic/_SvTermCommvoy1Tfp?_TMS=1042446970947&_DLG=SvTermCommvoy1Tfp&_TMS=1042446970909&OID_arrival=100042905&_AGENCY=VSC&OD_arrival=LYON+PART+DIEU&departure_choice=D&_LOCAL=com.webgl.fwk.navigation.session.FwkLocal%4058a3fb&TRAVEL_ID=1&departure_time_min=8&OID_departure=100042882&_LANG=FR&VbConshor2=com.webgl.vb.conshor.VbConshor2%4027e1ca&PIndex=1&OD_departure=PARIS+GARE+DE+LYON&departure_time_max=12&WebGLSession=PiJ6WRmIN7ClntHPbP3yo9MVAjCqytcDU9jg3A10tUAVAcDC5o1a|5243784726703956769/170395445/6/7251/7251/50443/50443/7251/-1
Line: 577

(there are other Javascript errors in the site, but this one blocks
buys/reservations)
Actual Results:  
Javascript error: PASSENTR0 is not defined. You can't get the next page, and if
you know nothing about the Javascript console, you have no clue what happens.
Really annoying.

Comment 1

16 years ago
Works for me in Moz 20030306 OSX. Benoît, please retest with a newer build.
Summary: Javascript error disallows online buys/reservations → sncf.com - Javascript error disallows online buys/reservations

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 184274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
move tristan's resolved euro west bugs to other
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.