Closed Bug 1888810 Opened 3 months ago Closed 2 months ago

Hide editing option of user profiles for users without corresponding authorization

Categories

(bugzilla.mozilla.org :: General, defect)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: Webworkr, Assigned: dkl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Linux; Android 14; Mobile; rv:126.0) Gecko/126.0 Firefox/126.0

Steps to reproduce:

Call up a bug on the smartphone.
The mobile view is loaded.

Actual results:

In contrast to the desktop view, a menu item for editing the profile is available next to each user profile. This action requires extended user rights.

Expected results:

This option should be displayed depending on the user group. Users without the appropriate authorization should not see this menu item.

(In reply to Denis Müller [:Webworkr] from comment #0)

User Agent: Mozilla/5.0 (Linux; Android 14; Mobile; rv:126.0) Gecko/126.0 Firefox/126.0

Steps to reproduce:

Call up a bug on the smartphone.
The mobile view is loaded.

Actual results:

In contrast to the desktop view, a menu item for editing the profile is available next to each user profile. This action requires extended user rights.

Expected results:

This option should be displayed depending on the user group. Users without the appropriate authorization should not see this menu item.

This is an issue only if you 1) log out and then 2) click back which reloads the cached version of the show bug page. If you hit refresh of the page after logging out, then it will display the user links properly and not display the drop down menu. Can you verify this still occurs if your refresh the page after logging out?

Flags: needinfo?(bugzilla.mozilla.org)

I think there is a misunderstanding here. It is not about the general view of the drop-down menu, but about the fact that the menu entries are not based on my user rights. In particular, it is about the "Edit" entry. With my user rights, I can only edit my own profile. Nevertheless, the "Edit" link is displayed next to every profile, even though I do not have user authorization to perform this action. In the desktop view, this "Edit" menu entry has never been displayed to me before.

Flags: needinfo?(bugzilla.mozilla.org)

(In reply to Denis Müller [:Webworkr] from comment #4)

I think there is a misunderstanding here. It is not about the general view of the drop-down menu, but about the fact that the menu entries are not based on my user rights. In particular, it is about the "Edit" entry. With my user rights, I can only edit my own profile. Nevertheless, the "Edit" link is displayed next to every profile, even though I do not have user authorization to perform this action. In the desktop view, this "Edit" menu entry has never been displayed to me before.

Sorry I did misunderstand before and now I see the issue. This is another regression due to the changes from bug 1157227 and i will fix this as it is a small change needed.

Assignee: nobody → dkl
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Type: enhancement → defect
Keywords: regression
Regressed by: 1157227
Summary: Mobile view of a bug: Hide editing option of user profiles for users without corresponding authorization → Hide editing option of user profiles for users without corresponding authorization
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Am I right in assuming that the change has been incorporated into the next update of Bugzilla, but the update has not yet been rolled out? (The "Edit" link is still visible.)

That is correct. I am working on rolling out a new deployment right now. The bug is normally closed when the change is committed to our main tree and not when it is live.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: