Installer accepts read-only volumes (e.g. CDs) as valid target directories

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
P1
normal
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Eli Goldberg, Unassigned)

Tracking

Trunk
All
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: for_dv)

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Installer accepts read-only volumes (e.g. CDs) as valid target directories

* STEPS TO REPRODUCE
0) Launch the Mozilla installer (11.15.99 build)
1) Insert a CD-ROM into your computer
2) Follow the platform-specific steps below...

Mac OS:
	a. proceed through the installer until you reach the screen with the
"Typical Install/Custom Install" pop-up menu.
	b. Press the "Select Folder" button, and choose the CD-ROM
	c. Click "Continue", and "Install"

Win32:
	- do the equivalent path as described for Mac OS, selecting a CD-ROM as the
write location.

* RESULT
 - What happened

The installer attempts to install on a write-protected volume.

 - What was expected

In both cases, the CD-ROM should have been rejected as an unacceptable
installation volume, and the user should not have been allowed to select it. On
the Mac OS, please try the 4.7 installer for a user-friendly implementation.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (11.15.99 build)
        Win32 Apprunner (a very recent M11 candidate build)

 - Doesn't Occur On
        Installer VISE (from Mac OS 4.7 install)
        InstallShield (from Win32 4.7 install)

* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).

Updated

18 years ago
Target Milestone: M15

Updated

18 years ago
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M18

Comment 1

18 years ago
Is the installer going to ship with mozilla? This still happens.
Keywords: ui

Comment 2

18 years ago
I suspect that mozilla releases (Mozilla .9 for example) will ship like any
other milestone.  We'll probably have an Installer version, a talkback version
and a plain zip version (the win32 example).

Comment 3

18 years ago
*** Bug 54971 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Priority: P3 → P1
Unsetting missed milestones to aid triage queries.
Target Milestone: M18 → ---
Keywords: nsbeta1
Not enough bandwidth right now, users will probably figure this out on their 
own.
Keywords: nsbeta1 → nsbeta1-

Updated

17 years ago
Keywords: nsbeta1

Updated

17 years ago
Keywords: nsbeta1-

Comment 6

17 years ago
Over to Syd for installer bug triage
Assignee: sgehani → syd
Status: ASSIGNED → NEW

Comment 7

16 years ago
Looks similiar to another bug that I'm triaging so I should probably take it.
Status: NEW → ASSIGNED

Updated

16 years ago
Blocks: 33074

Updated

16 years ago
Keywords: nsbeta1+
Target Milestone: --- → mozilla0.9.8

Comment 8

16 years ago
This should be fairly ez to fix, but is not nsbeta1+
Assignee: syd → curt
Status: ASSIGNED → NEW
Keywords: nsbeta1, nsbeta1+

Updated

16 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1-

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Whiteboard: for_dv

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 9

16 years ago
Resetting milestone of all nsbeta1-bugs, only nsbeta1+ bugs should have a target
milestone.
Target Milestone: mozilla1.0 → ---

Comment 10

16 years ago
Resetting milestone, only nsbeta1+ bugs can have a milestone on them, these are
niminated, but not yet plussed.

Comment 11

16 years ago
*** Bug 33074 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
this works the way it's supposed to with linux.

the installer attempts to make a Mozilla directory and fails, or if the user
attempts to install to a pre-existing directory, the installer immeadiately sees
that the directory is readonly and asks the user to select a different directory.

==> windows
Assignee: curt → general
Status: ASSIGNED → NEW
OS: All → Windows 98
QA Contact: agracebush → bugzilla

Comment 13

14 years ago
*** Bug 244070 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

12 years ago
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.