marketguide.com - cannot switch between rows to edit criteria that has already been entered

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Jim Choffo, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

I use a popular stock screening tool called NetScreen from Market Guide.  I
believe the underlying code is JavaScript.  When attempting to edit screen
criteria, the Mozilla browser will not allow editing of anything other than the
first line of screen criteria (cannot set another active line).  This makes it
impossible to edit/change previously created screens, or to modify a
saved/pre-defined screen and do a 'save as'.

Reproducible: Always

Steps to Reproduce:
1.Log in to NetScreen (may have to create a free account)
2.Create a screen or choose a pre-defined screen from drop-down 'Saved Screens'
3.Click on line other than line 1 and hit the 'Edit' button

Actual Results:  
Always brings up first line of screen criteria.

Expected Results:  
Should be able to open any line for editing.

First, I want to let you know what an excellent product this is.  I am very
happy with it and find it much more usable than IE.  Especially like tabbed
browsing and ability to turn off pop-ups without installing a pop-up killer.

Thanks again,

Jim Choffo
Jim, could you do me a favor:

1)  Open Tools > Web Development > JavaScript Console
2)  Clear it
3)  Repeat your steps to reproduce the bug
4)  Paste the contents of the console into this bug?
(Reporter)

Comment 2

15 years ago
Boris:

Thanks for quick follow-up.  As per your request, here is the output of the
JavaScript Console...

Error: document.layers has no properties
Source File: http://www.marketguide.com/screen/AScreen.asp
Line: 421

Error: document.layers has no properties
Source File: http://www.marketguide.com/screen/AScreen.asp
Line: 424

Error: document.layers has no properties
Source File: http://www.marketguide.com/screen/AScreen.asp
Line: 424

Error: document.layers has no properties
Source File: http://www.marketguide.com/screen/AScreen.asp
Line: 422

Error: origWidth is not defined
Source File: http://www.marketguide.com/nsfix.js
Line: 11

Thanks,

Jim
Jim, thanks.  Looks like the site does browser-sniffing and sends us JS that
uses document.layers -- a Netscape 4 extension that no other browser supports or
will ever likely support...
Assignee: rogerl → susiew
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US General
Ever confirmed: true
OS: Windows NT → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → zach
Hardware: PC → All
Version: Trunk → unspecified

Comment 4

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: cannot switch between rows to edit criteria that has already been entered → marketguide.com - cannot switch between rows to edit criteria that has already been entered
(Reporter)

Comment 5

15 years ago
Web site has been redesigned.  Bug is no longer reproducible.  Although bug has
not necessarily been fixed, it is no longer an issue for this site.

See http://www.multexinvestor.com/nscreen/builder.asp

Thanks again...
marking fixed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.