Closed Bug 1889703 Opened 3 months ago Closed 3 months ago

Re-introduce embedded migration wizard default title

Categories

(Firefox :: Messaging System, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
126 Branch
Iteration:
126.2 - Apr 1 - Apr 12
Tracking Status
firefox-esr115 --- unaffected
firefox124 --- unaffected
firefox125 --- verified
firefox126 --- verified

People

(Reporter: nsauermann, Assigned: nsauermann)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [omc])

Attachments

(4 files, 1 obsolete file)

Currently about:welcome import screen no longer has the default "Import Browser Data" title. This should be introduced as the default title.

Route to about:welcome select import checkbox, route to import screen, notice Import Browser Data title missing.

Assignee: nobody → nsauermann
Priority: -- → P1
Summary: Re-introduce embedded migration wizard default title in about:welcome → Re-introduce embedded migration wizard default title in about:welcome/about:preferences

Updated title as this is happening in about:preferences as well.

Not sure how I got into this scenario but about:preferences is NOT impacted.

Summary: Re-introduce embedded migration wizard default title in about:welcome/about:preferences → Re-introduce embedded migration wizard default title

Set release status flags based on info from the regressing bug 1876176

Attachment #9395090 - Attachment is obsolete: true

Re-introduces default title into embedded migration wizard which was regressed by https://phabricator.services.mozilla.com/D201142.

Same fix as https://phabricator.services.mozilla.com/D206683, but without the additional styling changes.

Original Revision: https://phabricator.services.mozilla.com/D206693

Attachment #9395129 - Flags: approval-mozilla-beta?

beta Uplift Approval Request

  • User impact if declined: Import title is missing in import step in about:welcome, might not be obvious to the user what action they're taking
  • Code covered by automated testing: yes
  • Fix verified in Nightly: no
  • Needs manual QE test: yes
  • Steps to reproduce for manual QE testing: Steps in phabricator test steps
  • Risk associated with taking this patch: None, fixes a regression caused by D201142
  • Explanation of risk level: Low
  • String changes made/needed: No
  • Is Android affected?: no
Flags: qe-verify+
Severity: -- → S3
Points: --- → 2
Status: NEW → ASSIGNED
Iteration: --- → 126.2 - Apr 1 - Apr 12
Pushed by nsauermann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70dd1bcd4d1a
Re-introduce embedded migration wizard default title r=migration-reviewers,aminomancer,mconley,omc-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Attachment #9395129 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I have verified this issue by following the steps provided here using Firefox Nightly 126.0a1, Build ID: 20240408090931 and Firefox Beta 125.0b9, Build ID: 20240405130120 on Windows 10 x64, macOS 13.6 and Linux Mint 21.1 and I can confirm that the "Import Browser Data" default title is displayed on the Import screen from the "about:welcome" page.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [omc]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: