-moz-use-text-color is sometimes serialized for the border shorthand

RESOLVED DUPLICATE of bug 376075

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 376075
15 years ago
2 years ago

People

(Reporter: Vladimir Ermakov, Assigned: glazou)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
If I set border property on one div to dotted, and set border-top property on
another div to dotted. When I get the values of borderTop of both divs from
javascript I get:
test0.style.borderTop = medium dotted -moz-use-text-color
test1.style.borderTop = medium dotted 

Which is inconsistent. There is no color for the second borderTop. I dont know
what is correct, to show the color, or not to show the color, but the two cases
should be consistent. Probably the right behaviour would be what IE does, just
show "dotted" because other properties are default.
(Reporter)

Comment 1

15 years ago
Created attachment 111443 [details]
testcase
glazou, the shorthand stuff needs to drop that color value...
Reassigning to glazman, Daniel, hand this back if you don't want it.
Assignee: jst → glazman
(Assignee)

Comment 4

15 years ago
Created attachment 112752 [details] [diff] [review]
fix #1
(Assignee)

Comment 5

15 years ago
Created attachment 112753 [details] [diff] [review]
rogggnnnnntdddjjjuuuuu, fix #2
Attachment #112752 - Attachment is obsolete: true
(Assignee)

Comment 6

15 years ago
Comment on attachment 112753 [details] [diff] [review]
rogggnnnnntdddjjjuuuuu, fix #2

kin, can you r= please ?
jst, can you sr= please ?
(given that bz seems to drop reviews...)
Attachment #112753 - Flags: superreview?(jst)
Attachment #112753 - Flags: review?(kin)
Attachment #112753 - Flags: superreview?(jst)
Attachment #112753 - Flags: superreview+
Attachment #112753 - Flags: review?(kin)
Attachment #112753 - Flags: review+
Daniel, plans to land this patch? It looks like it may have bitrotted a bit,
though....

Comment 8

15 years ago
This looks as if it would make the style string end in a space :-(
Hmm... that it could do, yes.  We probably want to avoid that...
QA Contact: ian → general
QA Contact: general → style-system
Summary: Inconsistent value for a property → -moz-use-text-color is sometimes serialized for the border shorthand
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376075
Fixed in patch 3 of bug 376075.
You need to log in before you can comment on or make changes to this bug.