Right-mouse delete of email deletes the wrong email

RESOLVED DUPLICATE of bug 168317

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 168317
16 years ago
14 years ago

People

(Reporter: Jeffrey C. Fried, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Right-mouse delete of email deletes the current email rather than the email
pointed to only when the current email appears after the email pointed to for
delete.  When the current email is before the email requested for delete, then
the behavior is correct.

Reproducible: Always

Steps to Reproduce:
1.Choose an email to view - call this the "current email"
2.Right-mouse over an email which preceeds the chosen email in the list
3.Pick "delete"


Actual Results:  
The "current email" is deleted.  (Undelete restores it!).

Expected Results:  
Mozilla should have deleted the email chosen in (2) above.

If the "current email" preceeds the email chosen for deletion, then the behavior
is correct and the chosen email is deleted.

Comment 1

16 years ago
dup of bug 168317?

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 168317 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
QA Contact: laurel → gchan
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.