Pref to block unrequested popups sometimes stops requested ones too

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Dan Tobias, Assigned: shliang)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030103
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030103

This is sort of an "inverse" of Bug 126224, and maybe related to Bug 159036 as
well.  The other bugs refer to cases where sites manage to sneak unwanted popups
on Mozilla users despite preference settings to disable them.  However, there
are also cases where a *requested* popup, with important content or navigation
for its site, is blocked by Mozilla preferences.  I've run into this several
times.  Most recently, it was from this link:

javascript:var meWindow =
window.open('/tf/fanmedia?tx=Router&cz=6180417041300&document_id=20030106200819887170329493&accountnumber='
+document.fixForm.accountnumber.value+'&searchaccount='+document.fixForm.accountnumber.value
+'&acct_buffer='+document.fixForm.accountnumber.value+','
+'&doctype=tax&setdb=&cmd=display&page_type=print&page=print991099consol',
'print991099consol', 'width=590,height=340,resizable,scrollbars,menubar');

(it won't work here, as it includes relative URLs, and I can't give the URL of
the page it's on since it's within a financial site requiring login)

This is a requested popup when I click on the link (it's in a normal A HREF tag)
(and I won't get into the debate about the desirability of using popups in a
site's design, even requested ones; I'm against it, but I still have to use
sites sometimes with developers that think otherwise).  However, Mozilla still
refuses to open the popup, and I have to change this preference to continue.


Reproducible: Always

Steps to Reproduce:
1. Uncheck "Advanced / Scripts & Plugins / Open unrequested windows" in Edit /
Preferences
2. Go to page that has a JavaScript link like the one above
3. Click on the link

Actual Results:  
Nothing

Expected Results:  
Opened the requested window

I love the popup blocking feature, but it needs a little fine tuning to try to
stop everything that needs stopping, but nothing else!

Comment 1

16 years ago
Popup blocking now (latest nightlies work with a few glitches) includes full
whitelist or blacklist support depending on your preference.  There is also an
optional visible alert (not shown in all themes) and audible alert for blocked
popups.  Whitelists can be managed from the alert icon.  Look in
Preferences->S&P->Popup windows.
Moving Popup Blocking bugs to XPApps, assigning to shliang
Assignee: mstoltz → shliang
Component: Security: CAPS → XP Apps

Comment 3

15 years ago
unable to reproduce any problems with javascript popup links. If a popup is
requested, it seems to work just fine for me. Tested Mozilla 1.7 beta. We also
have a whitelist for sites that do break so this bug is worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.