Closed Bug 1889934 Opened 4 months ago Closed 4 months ago

[LINUX] Firefox doesn't allow to use CSD when XDG_CURRENT_DESKTOP is not set

Categories

(Core :: Widget: Gtk, defect)

Firefox 125
All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1431429

People

(Reporter: aros, Unassigned)

Details

Steps to reproduce:

Steps to reproduce:

  1. Open a terminal application
  2. unset XDG_CURRENT_DESKTOP
  3. firefox

Actual results:

Firefox will not use CSD (Client Side Decorations) and will not allow to use them.

Expected results:

An option to use CSD regardless.

The only workaround is to export GTK_CSD=1 prior to running Firefox.

Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → All

Could be a dupe of bug 1431429.

Yeah indeed.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Duplicate of bug: 1431429
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.