(Scroll) position in page not restored after print preview

RESOLVED WORKSFORME

Status

()

P4
minor
RESOLVED WORKSFORME
16 years ago
9 months ago

People

(Reporter: bogdanb, Unassigned)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

When reading a web page, longer than one screen, and current view is in the
middle of the page, if I choose a print preview, after I close it the old
position (that is the view and position of the scroll bar) is not restored.

It is restored when I navigate with Forward/Back, but not after print preview.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.mozilla.org/
2. scroll at the bottom of the page
3. select File->Print Preview
4. click on Close

Actual Results:  
I can see the Mozilla.org logo -> scroll is at its top-most position.

Expected Results:  
Previous view to be restored -> I should read mozilla.org copyright notice
(bottom-most scroll position).

Comment 1

16 years ago
Confirmed in build 2003050714 on Windows NT.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → Future

Comment 2

15 years ago
*** Bug 204875 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Assignee: rods → core.printing
QA Contact: sujay

Comment 3

15 years ago
Please update Hardware/OS to All/All according to comments in bug 204875.

Comment 4

11 years ago
Mostly fixed here but scroller still doesn't stay at bottom.

Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Assignee: printing → nobody
QA Contact: printing

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.