[Mach-O] Real plug-in movie and controller chrome draw in the wrong place

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P2
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Chris Petersen, Assigned: Peter Lubczynski)

Tracking

({topembed+})

Trunk
Future
PowerPC
Mac OS X
topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Build: 2003-01-13-07 Mach-o
Platorm: OS X 10.2.3
Expected Results: Movie conroller should apper below video clip
What I got: Controller displays over navigation toolbar

Steps to reproduce:

1) Open attached test case from Cnet's site
2) Specific Real Player's speed connection
3) When video intializes, notice the placement of the controller
(Reporter)

Comment 1

15 years ago
Created attachment 111506 [details]
Testcase that uses Real content
(Reporter)

Comment 2

15 years ago
This is a Mach-O issue since the latest CFM build works correctly. Tested with
RealOne player 9.0.
(Assignee)

Comment 3

15 years ago
*** Bug 192973 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

15 years ago
nominating nsbeta1, setting to 1.4b
screenshot: http://bugzilla.mozilla.org/attachment.cgi?id=114228&action=view
Keywords: nsbeta1
Priority: -- → P2
Target Milestone: --- → mozilla1.4beta
*** Bug 193478 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Severity: critical → major
Keywords: realplayer
Summary: [Mach-O]Real Plugin movie controller appears over Navigation Toolbar → [Mach-O] Real plug-in movie and controller chrome draw in the wrong place

Comment 6

15 years ago
*** Bug 196906 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
This occurs in versions 1.3b and 1.3, but not in 1.3a.  I also had similar
issues with the quicktime plugin.

Comment 8

15 years ago
The controller also is displaying incorrectly in Camino 0.7.  This seems related
to Bug 193608 because Flash content is also showing up in the wrong location in
the browser.

Comment 9

15 years ago
*** Bug 201151 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
adt: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]

Comment 11

15 years ago
ADT: Nominating topembed
Keywords: topembed

Comment 12

15 years ago
*** Bug 205238 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
Please disregard my comment #8.  At the time both bugs were demonstrating
similar behaviors.  However, Bug 193608 seems to be Quicktime dependent.  The
Real Player plugin has not worked correctly since the switch to MachO builds. 
Firebird builds from May 5th and 6th also have this problem.

Comment 14

15 years ago
Discussed in topembed bug triage.  Plussing.  peterl can you comment on how you
will approach fix?
Keywords: topembed → topembed+

Comment 15

15 years ago
Is this the same as I see on these bbc video clips :

http://www.bbc.co.uk/comedy/reddwarf/video/

Max.
(Assignee)

Comment 16

15 years ago
This is similar to other painting bugs that started as a result of switching to
Mach-O or Cocco. Also see bug 162134.

Plugin vendors need to update their plugins for Mach-O.
Target Milestone: mozilla1.4beta → Future

Comment 17

15 years ago
*** Bug 219575 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
*** Bug 217946 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
*** Bug 214037 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 231970 has been marked as a duplicate of this bug. ***

Comment 21

14 years ago
*** Bug 232777 has been marked as a duplicate of this bug. ***

Comment 22

14 years ago
*** Bug 212357 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
*** Bug 211521 has been marked as a duplicate of this bug. ***
The symptom here seems to be the same as bug 19931.  In bug 19931, comment 17
there was reference to a method, FixMacPluginWindow, that fixed the problem
there; there's no patch on that bug so it's hard to say how/what the fix was.

Just thinking out loud, could FixMacPluginWindow only be valid for CFM and thus
be updated to work under Mach-O, if that's what was done for bug 19931?

Comment 25

14 years ago
WFM using RealPlayer 10.0.0 (v188) even on 1.6/Mac although Bug 162134
can be sometimes reproduced.
I think this may be marked as WFM.
This also works for me with the beta release of RealPlayer 10.  I'd mark this
resolved when the final version is released, assuming it still works.

Comment 27

13 years ago
*** Bug 262677 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
RealPlayer 10.0.0 (v.312) for Mac OS X has been released.
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 29

13 years ago
*** Bug 273571 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.