Can't see bottom half of the last line of EULA

RESOLVED FIXED

Status

SeaMonkey
Installer
P2
normal
RESOLVED FIXED
19 years ago
13 years ago

People

(Reporter: Eli Goldberg, Assigned: Samir Gehani)

Tracking

({pp})

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpibug])

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
[PP] Can't see bottom half of the last line of EULA

(noted by sfraser)

* STEPS TO REPRODUCE
0) Launch Mozilla installer
1) Scroll to the bottom of the License viewer

* RESULT
 - What happened

The bottom half of the bottom line is cut off.

 - What was expected

License should be viewable in its entirety.

* REGRESSION

 - Occurs On
        Mac OS Mozilla Installer (11.15.99 optimized build)

 - Doesn't Occur On
        Mac OS Netscape Installer (4.7 RTM, VISE-based)
        Win32 Mozilla Installer (an M11 candidate build, 11.13.99 I think)


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Assignee)

Updated

19 years ago
Target Milestone: M13
(Assignee)

Comment 1

18 years ago
Moving M13 bugs due to Samir's vacation

Updated

18 years ago
Keywords: pp

Updated

18 years ago
Summary: [PP] Can't see bottom half of the last line of EULA → Can't see bottom half of the last line of EULA

Comment 2

18 years ago
This bug may have gone away with new license file that is included
(Assignee)

Comment 3

18 years ago
Yes, I added a couple of lines at the bottom, purposely :o)  This is still a bug 
though.
(Assignee)

Comment 4

18 years ago
This has been temporarily worked around by adding a line in the License file.  
Moving off to M20.
Target Milestone: M14 → M20

Comment 5

18 years ago
Samir, the blank lines you inserted have disappeared, so again I can't read the 
last line of the license.

I think this is a blocker. Legally, if I can't read the whole of a license, how 
am I supposed to accept its terms?
(Assignee)

Comment 6

18 years ago
I was talking about the commercial license in my comments above, I believe.  At 
any rate, it's worth it no note that this is just a placeholder license.  
Someone from the mozilla community should supply a license they want displayed 
if different from the MPL.  If we find that this is in fact the license that 
should be displayed I'll toss in the extra line at the end.  Thanks for 
noticing.

Comment 7

18 years ago
Calling Mitchell ... Does a Mozilla user need to read and accept the MPL license 
in order to install Mozilla, or can we get rid of that blasted license screen 
altogether in non-commercial builds?

Comment 8

18 years ago
updating mac mozilla installer QA contact to me
QA Contact: gbush → asa

Comment 9

18 years ago
I think we can elimintae this in the mozilla installer.  should we update this
bug to reflect that or file a new one.
(Assignee)

Comment 10

18 years ago
Asa,
"elimintae this in the mozilla installer"  I'm not clear what you want to 
eliminate?  The license dialog?  It is non-trivial since the ``Show Dialog'' 
feature was cut for the Mac installer.  :(

Comment 11

18 years ago
See bug 51499.

Comment 12

18 years ago
Is the license only appearing on macos? [I'm trying to run through the win32 
installer and all open installer bugs] I don't see the license on win32.
Keywords: ui
(Assignee)

Comment 13

18 years ago
timeless,
The license is presented on Linux too.

Comment 14

18 years ago
Timeless: like I said, see bug 51499 ...

[Removing ui keyword because this does not require any UI design work]
Keywords: ui

Comment 15

18 years ago
perhaps we could replace it with a readme or something for mozilla builds.  In
the case that we keep the dialog (with either a license or a readme) then we
would need to fix the problem of not ebing able to see the last line of the
scrolling content.

Comment 16

18 years ago
mitchell says we need this. 
(Assignee)

Comment 17

18 years ago
Asa,
If we need the license, then is the current version the correct one (MPL 1.1 I 
believe)?

Comment 18

18 years ago
If we need the license, then why isn't it present in the Windows and Linux 
installers? That's a pretty striking omission.
(Assignee)

Comment 19

18 years ago
mpt,
It *is* in fact present in the Linux installers.  :o)

Comment 20

18 years ago
Samir, yes, MPL 1.1 is our current license.  It seems to only be missing from
the mozilla windows installer.
(Assignee)

Comment 21

18 years ago
Sean,
See last comment by Asa.  It appears that the Win32 mozilla installer needs to 
display MPL 1.1.
(Assignee)

Updated

18 years ago
Priority: P3 → P2

Comment 22

17 years ago
Since the license is required, this bug remains "Can't see bottom half of the
last line of EULA." This problem is still present in recent installers.
Changing obsolete M20+ milestones to closest equivalent, "Future"
Target Milestone: M20 → Future
Bringing on radar. Isn't this a dup of a bugscape bug (or vice versa)? If so 
let's close that one and keep the public one.
Keywords: nsbeta1
Target Milestone: Future → ---
Whiteboard: [xpibug]
Moz 0.9 tasks
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 26

17 years ago
Work-around is to put an extra line in the file... way easier and safer than any
fix in the installer itself.
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9 → ---
(Assignee)

Comment 27

17 years ago
Fixed while looking in the area this week.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.