Embedded jpg image not displayed inline from *.eml attachment

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: tho, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Unlike Outlook Express, Mozilla automatically displays *.eml attachments inline.
 An embedded *.jpg image in such an attachment will not be displayed.  Moreover,
opening the attached *.eml causes Mozilla to display only the character
equivalent of the message and not the message itself.

Reproducible: Always

Steps to Reproduce:
1. Send/receive an e-mail from/to yourself which contains a *.eml attachment.
2. Make sure the *.eml attachment contains a *.jpg image.
3. Open the top-level e-mail in the Mail & Newsgroups window then open the *.eml
attachment.
Actual Results:  
First stage: Large rectangular empty frame (except for icon) appears.  Second
stage: Character version of the embedded *.eml appears.

Expected Results:  
Displayed the *.jpg image in both cases.

Comment 1

15 years ago
*** Bug 189059 has been marked as a duplicate of this bug. ***
definitely not an imagelib bug

-> mailnews
Assignee: jdunn → mscott
Component: Image: GFX → Mail Back End
Product: Browser → MailNews
QA Contact: tpreston → esther
(Reporter)

Comment 3

15 years ago
Created attachment 111544 [details]
E-mail with attached *.eml containing embedded *.jpg

Comment 4

15 years ago
similar: bug 174692
Happens to me in Mozilla 1.3 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.3) Gecko/20030312). Looks indeed as a dup of 174692.
Created attachment 117832 [details]
Message eml with inline image

Message with inline jpg that doesn't show in preview pane but that it is ok in
the attachment list of the message (if you save the image and view it, it is
ok).

Comment 7

15 years ago
With 1.3 Final, I sent myself an HTML message with an embedded image, then 
forwarded that message as an attachment (to a plain-text message).  Viewing the 
plain-text message, the HTML message and the image both appeared inline in the 
correct order.

Is this bug still an issue for people with current builds of Mozilla?  If so, 
what is different between your procedure and the one described above?

Comment 8

15 years ago
Marking WFM per email received from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.