clicking on link while page loading causes hang (100% CPU)

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Judson Valeski, Assigned: Brian Ryner (not reading))

Tracking

({hang, topembed})

Trunk
x86
Windows XP
hang, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
using winxp build on trunk: 2003011412

Steps to repro:
1. load said URL
2. while page is still loading, quickly click one of the blue toolbar links
("home" "news" "sports" etc).
3. watch mozilla hang.

I don't see memory usage increase, just the CPU spinning.

I was able to repro this 100% in either tabbed, or non-tabbed browsing.
(Reporter)

Comment 1

16 years ago
after further playing, it occurs with any link (not just the blue toolbar) on
this page.

Comment 2

16 years ago
Wfm Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030114

Comment 3

16 years ago
I know this used to work, any idea if it is a recent regression?
Assignee: saari → bryner
Keywords: topembed
(Reporter)

Comment 4

16 years ago
can't repro today w/ the same build. closing.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
scratch that; now it's happening again.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

16 years ago
still seeing this w/ yesterday's winxp build (2003011713). I can repro in either
tabbed browsing mode, or no tabs.
(Reporter)

Comment 7

16 years ago
WFM in recent builds.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.