Closed Bug 1892738 Opened 1 month ago Closed 1 month ago

Flickering issue when positioning cursor near bottom line/corners of a tab

Categories

(Firefox :: Tabbed Browser, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
127 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox125 --- unaffected
firefox126 --- disabled
firefox127 --- verified

People

(Reporter: gmoldovan, Assigned: dwalker)

References

(Blocks 1 open bug, Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Found in

  • 126.0b3

Affected versions

  • 127.0a1 (2024-04-22)
  • 126.0b3

Tested platforms

  • Affected platforms: Ubuntu 22.04, Windows 11x64, macOS 13

Steps to reproduce

  1. Open a few tabs.
  2. Hover a random tab and move the cursor on the bottom line or bottom corners of the tab.

Expected result

  • No flickering is observed.

Actual result

  • A flickering behavior is observed when positioning the cursor on the bottom line/corners of the tab.

Regression range

  • Will look for one asap if there is one.

Additional notes

  • Attached a screen recording.
  • This issue does not reproduce if the cursor is on the top line or corners.

I have performed the regression range using Mozregression and the following results were obtained:

Regressed by: 1890397

:emilio, since you are the author of the regressor, bug 1890397, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(emilio)
Assignee: nobody → dwalker
Status: NEW → ASSIGNED

Thanks, DJ!

Flags: needinfo?(emilio)
Pushed by dwalker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84998870032e
prevent tab preview flicker when mouse moves near panel boundary. r=emilio,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 127 Branch

Verified as fixed on Firefox 127.0.a1 (20240502091633) across the following platforms: Win 10, macOS 12.6 and Ubuntu 22.04. No flickering is observed when hovering near the tab boundary.

Status: RESOLVED → VERIFIED
Regressions: 1894924
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: