Closed Bug 18928 Opened 20 years ago Closed 20 years ago

Malformed frameset is opens unless leaf is encountered

Categories

(Core :: HTML: Parser, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: rickg, Assigned: harishd)

References

()

Details

This opens a frameset:

<HTML>
<P>
<FRAMESET ROWS="50%,50%">
<FRAME Name="top" SRC="top.html"  target="top" Scrolling="No">
<FRAME Name="bottom" SRC="bottom.html" Scrolling="No">
</FRAMESET>
</HTML>

While this does not, because it encounters leaf content prior to <frameset>:

<HTML>
<P>text
<FRAMESET ROWS="50%,50%">
<FRAME Name="top" SRC="top.html"  target="top" Scrolling="No">
<FRAME Name="bottom" SRC="bottom.html" Scrolling="No">
</FRAMESET>
</HTML>
*** Bug 18757 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: M13
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed by improvements to heuristics used to deal with badly formed framesets.
Assigning bug to myself.
Status: RESOLVED → REOPENED
CCing rickg.
Assignee: rickg → harishd
Status: REOPENED → NEW
Clearing FIXED resolution due to reopen of this bug.
Resolution: FIXED → ---
FIXED by opening up BODY, irrespective of a FRAMESET document, if 'text' is seen 
in the document -- quirks mode fix.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
updated qa contact.
QA Contact: janc → bsharma
Verified on:
Build: 2001-04-25-09-Trunk
Platform: WinNT

The test case with leaf is opened correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.