no "quit" keyboard shortcut such as Ctrl+Q

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
4 years ago

People

(Reporter: lee, Assigned: myk)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021213 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021213 Phoenix/0.5, build 2003011605

menu file -> quit does not have a keyboard shortcut to quit.

Reproducible: Always

Steps to Reproduce:
1.start phoenix
2.view file menu
3.observe that quit does not have a keyboard shortcut

Actual Results:  
there is no keyboard shortcut such as Ctrl+Q to quit phoenix

Expected Results:  
quit phoenix upon pressing Ctrl-Q (or equivalent) on keyboard

Comment 1

16 years ago
This has been discussed before and will not be added.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

16 years ago
for the benefit of potential future bug writers concerned with keyboard shortcut
to exit phoenix completely, please refer to bug 161495, bug 171892 and bug 65121.

Comment 3

15 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Comment 5

15 years ago
*** Bug 229014 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 230834 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
If I remember correctly, gnome/gtk once had a feature where you could set up the
shortcuts for menu items yourself.

Alas, I doubt it would apply to firefox' look-like-gtk menu widget and I can't
seem to find it anymore in gtk apps. Would be great to have a way like that to
avoid these flamewars and decide what's best for me myself though.
(Reporter)

Comment 8

15 years ago
what really chaps me about all this is that for both the mozilla suite and
thunderbird mail standalone app, ctl-q is the keyboard shortcut for the menu
item "quit", and "quit" in those applications behaves as expected for me.

yet for some reason the firefox standalone browser app does not impliment this
keyboard shortcut -- despite the existence of the "quit" menu item in firefox
and it behaves as expected (i.e., consistent with other mozilla.org products).

oddly, when i load an irc:// url into firefox, then type ctl-q in the resulting
chatzilla app, the keyboard shortcut behaves as expected.  both chatzilla and
firefox exit completely.  

if it's a ui standards issue, then mozilla.org's standards implimentation is
flawed and inconsistent.

unless i'm missing something that hasn't been fully explained.

can anyone explain?  please?

if there's no explanation, then this bug should be reopened and addressed.  if
this bug will not be fixed, then bugs should be filed to remove the ctl-q
keboard "quit" shortcuts for mozilla suite and thunderbird.  

Comment 9

15 years ago
This is one of the most important features missing from whatever the browser is
called now IMHO. It doesn't feel right if I can't hit something on the keyboard
to quit it. In ten years of using browsers I can't remember accidentally
quitting one.

Can't someone at least make an XPI to fix this bug?
*** Bug 298580 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
*** Bug 316350 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
*** Bug 320230 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: bugzilla → menus

Comment 13

13 years ago
Weird.

Ctrl+Q is a standard for Gnome applications (with a few exceptions, maybe). And Cmd-Q is a standard on OS X.
Furthermore, we now have a warning dialog that pops up after choosing File > Quit. It prevents accident quits. Why can't we have a standard keyboard shortcut for that? At least on Mac/Linux?

Comment 14

13 years ago
> Cmd-Q is a standard on OS X.

This bug is not about MacOS X (and Cmd-Q should work there).

> Why can't we have a standard keyboard shortcut for that?

I guess because there still is no warning dialog if there are multiple windows open and each window contains only one tab. The dialog is only displayed when there are multiple tabs in a window.

Comment 15

13 years ago
(In reply to comment #14)
> > Cmd-Q is a standard on OS X.
> 
> This bug is not about MacOS X (and Cmd-Q should work there).

Maybe it's possible to also make Ctrl-Q work on Linux?
Let the quit command have no shortcut in Windows, where Ctrl-Q isn't that standard anyways.

> > Why can't we have a standard keyboard shortcut for that?
> 
> I guess because there still is no warning dialog if there are multiple windows
> open and each window contains only one tab. The dialog is only displayed when
> there are multiple tabs in a window.

Ah, I missed that part.

Comment 16

12 years ago
Bad choice, people. It's a good idea to have this shortcut.
(Assignee)

Comment 17

11 years ago
Created attachment 292040 [details] [diff] [review]
patch to implement shortcut

I realize this bug has been wontfixed, but I think it would be reasonable to reconsider.
Assignee: bugzilla → myk
Status: VERIFIED → ASSIGNED
Ever confirmed: true
Attachment #292040 - Flags: review?
Resolution: WONTFIX → ---

Comment 18

11 years ago
I accidentally press Ctrl+Q when I mean to press Ctrl+W in Mac OS X and it's always a disaster! However, if Ctrl+Q is a platform standard in Linux, it deserves to be there just as much (or, frankly, little) as in Mac.

Is quitting an application entirely, including all opened windows, such a commonly used feature that it needs a shortcut?

Comment 19

11 years ago
talking about accidents...
I am very used to using Shift+Del in Thunderbird (and not just in it). But sometimes I accidently press Shift+End+Del, and guess what happens (assuming my newest messages, and my current selection is at the top of the list). A few hundred messages are gone for good each time I do this.

Does that mean Shift+Del should be disabled in Thunderbird? I don't think so... However, it could warn me when Shift-deleting more than, say, 10 or 20 messages... Perhaps, that deserves a feature request too.

Same here (back to the topic). How about the concerns expressed in Comment #14? Have, or will they been addressed? If yes, then I'd say let's use Ctrl+Q on windows also! If not yet, then they should IMO be addressed first.
(Assignee)

Comment 20

11 years ago
Sorry, I should have commented in more detail when submitting the patch.  There are two reasons I think this deserves reconsideration.

First, the GNOME HIG says to do it, while the KDE HIG calls it a "standard" binding.  If we follow the Apple HIG's recommendation regarding the Command-Q shortcut on Mac OS X, then it seems like we should be following the GNOME and KDE HIG's recommendations for Ctrl-Q on Linux as well.

Second, now that we have session restore, and we prompt users to use it when quitting the application, users are less subject to the danger of losing their work by accidentally quitting the app.  So this is less of a concern than it was when this fix was originally wontfixed.

GNOME HIG: 

"If your application uses any of the standard functions listed in the following tables, use the recommended standard keyboard shortcut for that function.
...
Quit 	Ctrl+Q 	Quit the application"

<http://library.gnome.org/devel/hig-book/stable/input-keyboard.html.en#standard-shortcuts>

KDE HIG: 

"The following keys are the standard shortcut key bindings included in the KDE distribution. For the sake of consistency, application programmers should never  redefine these keys in their programs to have functionalities other than those listed below.
...
Quit	Ctrl+Q	Quit the application"

<http://developer.kde.org/documentation/standards/kde/style/keys/shortcuts.html>

Apple HIG:

"In addition to the keyboard shortcuts reserved by the system, there are a large number of keyboard shortcuts that have a well established meaning, such as Command-S for Save and Command-Q for Quit. Users accustomed to running applications in Mac OS X expect these keyboard shortcuts to be available and to mean the same thing in each application they use. An application that overrides these shortcuts, such as one that uses Command-Q for a Query command instead of Quit, runs the risk of unnecessarily confusing and frustrating its users.

These common keyboard shortcuts are not reserved by the system, but they are highly recommended for applications that offer the associated commands."

<http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGUserInput/chapter_11_section_3.html#//apple_ref/doc/uid/TP30000361-CHDIGFBH>

Comment 21

11 years ago
(In reply to comment #20)
I guess you want to ask for a review then...

Updated

11 years ago
Version: unspecified → Trunk
(Assignee)

Comment 22

11 years ago
Comment on attachment 292040 [details] [diff] [review]
patch to implement shortcut

(In reply to comment #21)
> (In reply to comment #20)
> I guess you want to ask for a review then...

Yes, indeed, I just need to update the patch to make the shortcut key localizable.
Attachment #292040 - Flags: review?
(Assignee)

Updated

11 years ago
Duplicate of this bug: 274501
(Assignee)

Comment 24

11 years ago
Created attachment 295937 [details] [diff] [review]
patch v2: with localizable shortcut key, platform ifdefs

Here's a complete patch with a localizable shortcut key and platform-specific ifdefs so that we only define this key on Unix (including Mac OS X) platforms.

Note that per bug 274501, comment 2 and bug 274501, comment 4 the blocker for accepting a patch like this is that File > Quit skipped confirmation when multiple windows with a single tab each are open.  That's no longer the case, as we now prompt users in that situation, as described in bug 274501, comment 18, so that's no longer a blocker.
Attachment #292040 - Attachment is obsolete: true
Attachment #295937 - Flags: review?(mconnor)
(Assignee)

Comment 25

11 years ago
Requesting wanted-firefox3 for this platform integration fix.
Flags: blocking-firefox3?

Updated

11 years ago
Duplicate of this bug: 414616
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
(Assignee)

Comment 27

11 years ago
Created attachment 305319 [details] [diff] [review]
patch v3: updated to trunk

This is the same as patch v2 but applies cleanly to the trunk.
Attachment #295937 - Attachment is obsolete: true
Attachment #305319 - Flags: review?(mconnor)
Attachment #295937 - Flags: review?(mconnor)
(Assignee)

Updated

11 years ago
Blocks: 420371
(Assignee)

Comment 28

11 years ago
Created attachment 306601 [details] [diff] [review]
patch v4: doesn't change entity name

This version reverts the entity name change per discussion on IRC with Gavin that it is late in the Fx3 cycle to be taking such changes unnecessarily.  I have filed bug 420371 on fixing that in the future.
Attachment #305319 - Attachment is obsolete: true
Attachment #306601 - Flags: review?(gavin.sharp)
Attachment #305319 - Flags: review?(mconnor)
Comment on attachment 306601 [details] [diff] [review]
patch v4: doesn't change entity name

I think this needs ui-r.
Attachment #306601 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 30

11 years ago
Comment on attachment 306601 [details] [diff] [review]
patch v4: doesn't change entity name

Requesting UI review for this Linux keyboard shortcut fix.  Note that the reasons for originally not having this keyboard shortcut (the danger of losing data when quitting accidentally) have since been resolved via warnings when quitting the application, and mconnor recently voiced his support for this change on IRC, given those shutdown warning changes.
Attachment #306601 - Flags: ui-review?(beltzner)

Comment 31

11 years ago
I've just filed a clone Bug 420688 for Windows.
Attachment #306601 - Flags: ui-review?(beltzner) → ui-review+
(Assignee)

Comment 32

11 years ago
Comment on attachment 306601 [details] [diff] [review]
patch v4: doesn't change entity name

Requesting approval for this small, well-understood, low-risk accessibility and platform integration fix.
Attachment #306601 - Flags: approval1.9?
Comment on attachment 306601 [details] [diff] [review]
patch v4: doesn't change entity name

a1.9=beltzner
Attachment #306601 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 34

11 years ago
Checking in browser/base/content/browser-menubar.inc;
/cvsroot/mozilla/browser/base/content/browser-menubar.inc,v  <--  browser-menubar.inc
new revision: 1.143; previous revision: 1.142
done
Checking in browser/base/content/browser-sets.inc;
/cvsroot/mozilla/browser/base/content/browser-sets.inc,v  <--  browser-sets.inc
new revision: 1.113; previous revision: 1.112
done
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago11 years ago
Resolution: --- → FIXED
verified fixed using  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030704 Minefield/3.0b5pre.
Status: RESOLVED → VERIFIED

Comment 36

10 years ago
I disagree with this bug.
I hit this unintentionally several times now.
Sorry for the language, but this is just brain-dead. The 200-times-per-day shortcut Ctrl-W (close tab) is right next to the "you must never ever hit this or all your context, read-this-later pages and textfields are gone" shortcut Ctrl-Q. There isn't hardly any worse shortcut than this.

I wondered why I haven't been hit by this earlier - now I know why.

If the GNOME/KDE HIGs says this, they are wrong. Linux HIGs never were masterpieces anyways.

Please back this out or at least ensure that a warning is shown.
I lost a lot of open pages several times now.

> Second, now that we have session restore, and we prompt users to use it
> when quitting the application

I don't get any prompt whatsoever.
I have browser.warnOnQuit on true (default), but got no prompt either way.
I have browser.tabs.warnOnClose on false (user), intentionally, because I routinely close windows with many tabs and don't want a warning (otherwise I'd see it so often that I'd quickly ignore all warnings of any nature).

Comment 37

10 years ago
BTW: Note the difference between GNOME and KDE/Apple HIG. The latter say not to use the standard key for another function, but do not mandate the usage of this particular shortcut. None of them mandates the shortcut to exist at all.

Comment 38

10 years ago
Ben, I think your problem is that Session Restore doesn't work as intended, and not that Ctrl+Q is a bad shortcut. 

Firefox doesn't ask me whether I want to quit either, but I always thought it's because I have set it to open last session tabs when launched.

I'm not sure, but I may have told it to never ask me again (about quitting) in the past though....

Comment 39

10 years ago
Compare bug 52821, with lots of enraged users about this.

Rimas, session restore works fine for me - in case of a crash.
It does not prompt me on Quit. And bug 39057 was WONTFIXed.
I agree that a warning dialog would solve the problem, but:

What I don't understand is why such a rare option needs a keyboard shortcut. Note that you have Alt-F4 to close the current window, which I agree is important as shortcut. If you need to access App Quit per keyboard, you can do Alt-F, Up, Enter, which I think is fair enough given that it's only used very rarely or by very few users more often.
(Assignee)

Comment 40

10 years ago
> I don't get any prompt whatsoever.
> I have browser.warnOnQuit on true (default), but got no prompt either way.
> I have browser.tabs.warnOnClose on false (user), intentionally, because I
> routinely close windows with many tabs and don't want a warning (otherwise I'd
> see it so often that I'd quickly ignore all warnings of any nature).

The reason you don't see a warning is that browser.warnOnQuit is ignored when browser.tabs.warnOnClose is false.  Those prefs should be independent, so you can configure Firefox to prompt you when you quit it.  I have filed bug 463308 on that.


(In reply to comment #39)
> What I don't understand is why such a rare option needs a keyboard shortcut.
> Note that you have Alt-F4 to close the current window, which I agree is
> important as shortcut. If you need to access App Quit per keyboard, you can do
> Alt-F, Up, Enter, which I think is fair enough given that it's only used very
> rarely or by very few users more often.

Alt-F4 is cumbersome to use and results in dataloss if you have multiple windows open and close them one at a time (and browser.tabs.warnOnClose is false, which seems to happen automatically under some circumstances).  Alt-F, Up, Enter is even more cumbersome to use.

I think quitting Firefox is a common enough action, and the Ctrl/Command-Q shortcut a familiar enough convention, to justify the presence of this shortcut.
Depends on: 938303
You need to log in before you can comment on or make changes to this bug.