:hover combined with an adjacent sibling selector doesn't update adj. sibling on mouseover

RESOLVED DUPLICATE of bug 15608

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 15608
15 years ago
15 years ago

People

(Reporter: Martin van Dijken, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Check out the above html. When you move your mouse on one of the h's in the
page, the stylesheet defines that the H should be doubled in size. Also, the H
right next to it, should be 1.5 times it's normal size. The first works, the h
under the mouse is enlarged. The latter works really weird. Initially it doesn't
do anything at all. When the mouse is moved to an h left of the current h, the
behaviour starts to work. It is not however updated when the mouse is moved
further left. When the mouse is moved to the right, the style is removed.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 15608 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.