Closed Bug 18938 Opened 20 years ago Closed 20 years ago

[DOGFOOD][REGRESSION][BLOCKER][PP] Apprunner freeze when msgCompose call nsIEditor::BeginningOfDocument

Categories

(Core :: Editor, defect, P3, blocker)

Other
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: mozeditor)

References

Details

On linux only, when you reply to a message (bug 18922) in HTML mode, the whole application freeze.

We hit an infinity loop when message compose try to position the cursor at the top of the body using the call
nsIEditor::BeginningOfDocument. It's simillar to bug 18723 but not a duplicate of it
Blocks: 18922
Summary: [PP] Apprunner freeze when msgCompose call nsIEditor::BeginningOfDocument → [PP][Dogfood] Apprunner freeze when msgCompose call nsIEditor::BeginningOfDocument
Severity: major → blocker
Summary: [PP][Dogfood] Apprunner freeze when msgCompose call nsIEditor::BeginningOfDocument → [DOGFOOD][REGRESSION][BLOCKER][PP] Apprunner freeze when msgCompose call nsIEditor::BeginningOfDocument
Target Milestone: M12
setting to M12
This looks like a dup of http://bugzilla.mozilla.org/show_bug.cgi?id=18922

yes?
in Fact bug 18922 is the side effect of this bug. You should rather mark bug 18922 a dup this bug... And add PDT+ to
it.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed - problem was the usage of an unfinished iterator feature: MakePre().  I
rewrote nsEditor::GetFirstEditableNode() and nsEditor::GetLastEditableNode() to
not use this iterator feature (indeed to not use iterators at all).

It works fine now although the caret might not be where you expect in the
EndOfDocument() case: it appears at the end of the quoted text rather on a line
after it.  However, when you type the new text appears in the right place.  I
think the caret issue will be fixed by some work I'm checking in later this week.
ducarroz, does this happen for you anymore??
I cannot verify this fix until Monday as I don't have a Unix box at home. Maybe
somebody in mailnews qa can do it? I will send them an email...
Status: RESOLVED → VERIFIED
Per request, I am verifying this bug.
Using Linux Redhat 6.0 (1999-11-23-08 M12)build
IMAP/POP:  When I reply to a message in HTML mode, it  works fine.
You need to log in before you can comment on or make changes to this bug.