hotmail.com - continually asks me to save the file ADSADClient31.dll

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Trent Davis, Unassigned)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

In hotmail I am continually asked to save ADSADClient31.dll to my harddisk. 
This occurs everytime I attempt to move to another page (i.e. from my inbox to
compose, or when I check POP mail.  Perhaps this is just a case of knowing where
to save this file and it will then stop asking me or maybe it is a bug.  Thanks
for your help!

Reproducible: Always

Steps to Reproduce:
1.go to hotmail
2.log into hotmail using any email account
3.the problem should present itself

Actual Results:  
the problem occured

Expected Results:  
No clue, I love Mozilla!

Comment 1

15 years ago
Created attachment 111804 [details]
ScreenShot with Dialog and error

Comment 2

15 years ago
This happens to me also:  I'm using Phoenix .5 WinME though 

About:
(Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5)  

I'm submitting a screenshot too, if it would help at all.
(Reporter)

Comment 3

15 years ago
Created attachment 111808 [details]
screen shot of problem

screen shot of problem

Comment 4

15 years ago
I'd bet $5 that this is actually due to faulty IE-specific scripting in Hotmail
(aka Tech Evangelism).

Someone should save the source code from an affected page and attach it here for
analysis.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Summary: continually asks me to save the file ADSADClient31.dll → hotmail.com - continually asks me to save the file ADSADClient31.dll

Comment 5

15 years ago
I'm getting this too, but it's combined with a more worrisome problem.  My
browser (1.3) actually downloads and attempts to execute the DLL (which brings
up a Windows "you are attempting to open a file of type 'Application Extension'
(.dll)" dialog.  I've looked through the security settings, and I just can't
find any option that would automatically open a file rather than ask if I want
to open it.

Comment 6

14 years ago
anyone can still see this problem?
Assignee: asa → english-us
Component: Browser-General → English US
Product: Browser → Tech Evangelism
QA Contact: asa → english-us
Version: Trunk → unspecified

Comment 7

14 years ago
Sorry, wouldn't know. I haven't touched Hotmail since they switched to Passport.

Comment 8

12 years ago
*** Bug 323027 has been marked as a duplicate of this bug. ***

Comment 9

11 years ago
Created attachment 262357 [details]
Screenshot of dialogue box with download window

Wow, this is an old bug. Strangely enough, I have never encountered it before, and I have been using Mozilla regularly since version 0.8 (Suite), all through Phoenix until now, when this suddenly happened in Firefox 2.0.0.3:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I have also created a screenshot with the dialogue box asking to download ADSAdClient31.dll. Might it have something to do with MIME settings? I have the impression it only happens on my notebook and not on my desktop at home, but since the desktop is in England and I'm in China I'm in no position to check that right now. In any case, I suspect that people who have experienced this bug must have a setting in common with each other and it does not seem a very straightforward bug to duplicate.

Comment 10

11 years ago
It is just my opinion, but I think this is either due to a small number of misconfigured server's or an uncommon bug that sends a response without the appropriate mime type. Without the mimetype, we interpret the response as an unknown, unsafe content type and refuse to display it.

Comment 11

11 years ago
I had the same experience but discovered the answer to the problem on the web.

What you need to do is

1. Download and install the free Adblock plug-in for Firefox from here:

https://addons.update.mozilla.org/extensions

2. Restart Firefox

then...

3. Tools / Extensions / Adblock

Right-click then choose Options

4. Click in New filter and type:

http://rad.msn.com/adsadclient31.dll

You can then read Hotmail without the MS prompts.

Comment 12

4 years ago
Hotmail was retired in 2013 in favour of Outlook.com.  As far as I can tell the web interface is completely different, so I suspect this bug can be closed.

Comment 13

4 years ago
lets call this 10 year old issue wfm and open any new issues with outlook.com separately. Tristan, thanks for the reminder!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.