Node.nextSibling does not get nextSibling

RESOLVED DUPLICATE of bug 26179

Status

()

RESOLVED DUPLICATE of bug 26179
16 years ago
11 years ago

People

(Reporter: declercq.bart, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

In an onclick event I do "var obj = obj.nextSibling;", I expect the next node
but in stead get something else (obj.nodeType gives "3" as the response.

Doing var obj = obj.nextSibling.nextSibling; gets me to the nextSibling
correctly and the DomInspector shows a #text "object" as the first node
following my <h1></h1>.

Placing the tags on one line gives the correct result.

Reproducible: Always

Steps to Reproduce:
1.Create a HTML document with two sibling elements in the body, with a CR/LF
between them.
2. in the onclick event of the first element, retrieve the nextSibling and
examine it.


Actual Results:  
It apparently retrieves the CR/LF as a Node in the DOM-tree.

Expected Results:  
CR/LF should be ignored as whitespace
The nextSibling is correct....

*** This bug has been marked as a duplicate of 26179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.