Set message format preference for contacts/domain

RESOLVED DUPLICATE of bug 44494

Status

SeaMonkey
MailNews: Address Book & Contacts
--
enhancement
RESOLVED DUPLICATE of bug 44494
15 years ago
13 years ago

People

(Reporter: Andrew Sterling Hanenkamp, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021226 Debian/1.2.1-9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021226 Debian/1.2.1-9

When sending a formatted message to an address whose domain or individual has
not been assigned a format preference, you get the "HTML Mail Question" box that
asks whether to send as plain text, HTML, or both.

I suggest adding two checkboxes that are enabled when either text or HTML is
selected:
  o Remember this choice when sending to addresses in the same domain.
  o Remember this choice when sending to this address.

The domain preference would then add the domain to the "HTML and Plain Text
Domains" configuration. The address preference would then add the "Prefers to
receive messages formatted as:" on the address card.

There are some other factors that will have to taken into consideration,
obviously. Such as, if automatic address collection is turned off and this is an
uncollected address, etc.

Reproducible: Always

Steps to Reproduce:
Product: Browser → Seamonkey

Comment 1

13 years ago
Related to/(partial) duplicate of Core bug 44494?
(In reply to comment #1)
> Related to/(partial) duplicate of Core bug 44494?

Yes, I think that this is a duplicate of that bug.

*** This bug has been marked as a duplicate of 44494 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.