Clicking on the XPI link crashes Mozilla [@ CertReader::OnStopRequest ]

RESOLVED FIXED

Status

Core Graveyard
Installer: XPInstall Engine
--
critical
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: Olivier Cahagne, Assigned: timeless)

Tracking

({crash, regression, topcrash})

Trunk
crash, regression, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
build ID: 2003011708

Steps to reproduce:
1. Click on URL http://downloads.mozdev.org/tinderstatus/tinderstatus-0.1.xpi
2. Mozilla crashes.

Talkback ID: TB16305011Q.
(Reporter)

Updated

15 years ago
Whiteboard: TB16305011Q
confirmed with 200311713 WindowsXP, happens also for xpis open from a local drive

Talkback ID : TB16307476Y

Setting OS to ALL
OS: Linux → All

Comment 2

15 years ago
CertReader::OnStopRequest
[c:/builds/seamonkey/mozilla/xpinstall/src/CertReader.cpp, line 256]
nsFileChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/file/src/nsFileChannel.cpp, line 596]
nsOnStopRequestEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 664]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 597]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1386]
USER32.dll + 0x4455 (0x77d14455)
USER32.dll + 0x95d5 (0x77d195d5)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 471]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1572]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1930]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1951]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e614c7) 
Component: Browser-General → Installer: XPInstall Engine
Keywords: stackwanted

Comment 3

15 years ago
really moving
Assignee: asa → dveditz
QA Contact: asa → jimmylee

Comment 4

15 years ago
over to timeless
Assignee: dveditz → timeless
(Reporter)

Comment 5

15 years ago
culprit: bug 187297.
Keywords: regression
Hardware: PC → All
Summary: Clicking on the XPI link crashes Mozilla → Clicking on the XPI link crashes Mozilla [@ CertReader::OnStopRequest ]
Whiteboard: TB16305011Q
(Reporter)

Comment 6

15 years ago
kw: +topcrash, +zt4newcrash after reading bug 154709 comment 0, all the criteria
apply to this bug.
Flags: blocking1.3b?
Keywords: topcrash, zt4newcrash

Comment 7

15 years ago
confirmed Build ID: 2003011808

Comment 8

15 years ago
related : bug 184289
It seems like the fix for bug 187297 should be backed out and you should fix
http://lxr.mozilla.org/seamonkey/source/xpinstall/src/nsXPInstallManager.cpp#121
instead.
(Well, not the whole fix, but the do_QueryInterface bit of it.)
Created attachment 111951 [details] [diff] [review]
possible fix

This ought to fix it.  Untested, though.
Comment on attachment 111951 [details] [diff] [review]
possible fix

I've tested that this fixes the crash, and I think it's pretty clear that it
will fix the assertion too, since nsXPInstallManager seems to be the only
implementation of the interface.
Attachment #111951 - Flags: superreview?(dveditz)
Attachment #111951 - Flags: review?(timeless)
(Assignee)

Updated

15 years ago
Attachment #111951 - Flags: review?(timeless) → review+
(Reporter)

Comment 13

15 years ago
*** Bug 189642 has been marked as a duplicate of this bug. ***
Comment on attachment 111951 [details] [diff] [review]
possible fix

sr=dveditz
Attachment #111951 - Flags: superreview?(dveditz) → superreview+
Fix checked in to trunk, 2003-01-19 12:01 PST.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Flags: blocking1.3b?
(Reporter)

Comment 16

15 years ago
*** Bug 189756 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
this fix doesn't fix neither bug 184289 nor bug 186389
Crash Signature: [@ CertReader::OnStopRequest ]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.