Infinite busy-wait at startup if lockfile not properly erased by prior invocation

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Evan, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

I have had a few instances where Mozilla was terminated by another program(e.g.
Software Update's MustRebootNow feature), and the parent.lock file was not
properly removed.  If I attempt to start mozilla without deleting the file from
my user preferences directory, it goes into an infinite wait state, eating up
all available processor cycles.

Reproducible: Always

Steps to Reproduce:
1.start mozilla
2.copy parent.lock to some other location
3.stop mozilla
4.copy parent.lock back into user prefs directory
5.attempt to restart mozilla

Actual Results:  
symptoms described above: infinite busy-wait

Expected Results:  
removed bad lock file(or prompt user about it).

In know that netscape prompts user when the lockfile is still there... this at
least allows the user to know he has to erase it.

Comment 1

15 years ago
Evan, can you still reproduce this problem using a current nightly build?

(Dup of/related to bug 151188?)
Summary: infinite busy-wait at startup if lockfile not properly erased by prior invocation → Infinite busy-wait at startup if lockfile not properly erased by prior invocation

Comment 2

15 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.

Comment 3

14 years ago
Is that the same bug?

I login as a normal user, and Mozilla 1.4 doesn't start. It creates the 'lock'
file and a XUL.mfast file of 0 bits long. I logout and re-login as root: Mozilla
starts normally. Logout and re-login as the first normal user. Under the
directory ~/.mozilla/profile/ there are 4 files which are owned by root. Chown
and chgrp to user these files, and now Mozilla runs perfectly. The XUL.mfast
file now is 2Mb long.
Depends on: 151188
(Assignee)

Comment 4

14 years ago
Over a year since follow-up was requested. Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
No longer depends on: 151188
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.