If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page scrolling performance scrolls slower and more jerky than IE 5.1..

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Matt Carrell, Unassigned)

Tracking

({perf})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

Noticably slower than on Internet Explorer 5.1 (surprise!) and Chimera.
Similar bad perfomance on Mozilla 1.3.
Scrolling frame of concern has no plug-ins or Java.
The top non-scrolling part has minimal JavaScript for rotatings ads.

Scrolls MUCH more jerky than the slow scroller reported in #188208.


Reproducible: Always

Steps to Reproduce:
1.  Go to
http://mentalhealth.about.com/gi/dynamic/offsite.htm?site=http%3A%2F%2Fwww.mhsanctuary.com%2Fborderline%2Ffreerx.htm
2.  Scroll page up and down.


Actual Results:  
Slow performance.  Worse than IE.  About as bad in Mozilla 1.3.

Expected Results:  
It should have been faster than IE if the trend holds true.

Test system: G4 iMac (GF2MX / Quartz Extreme)... OS 10.2.3
(Reporter)

Updated

15 years ago
Keywords: perf
Summary: Page scrolling performance scrolls slower and more jerky than IE 5.1.. → Page scrolling performance scrolls slower and more jerky than IE 5.1..

Comment 1

15 years ago
WFM, some of their ads are using jumping/shaking banner via javascript, be sure
to make the tests when the banner is a non-jumping one.
With a jumping ad, the scrolling is slower as the moves frequency is high.
Marking Invalid, Matt reopen it if you think it's not correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
Reload the page until the same "shaking" ad pops up on Chimera and IE and compare.. Chimera is slower rending the same page with the same ad than IE.. (besides, why should the shaking ad make a huge performance hit on the page when the ad is not updated on the screen for as long as the scroll bar is held down?)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

15 years ago
Really slow in 1.2.1 Mozilla as well.
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Chimera → Browser
Version: unspecified → Trunk

Updated

15 years ago

Comment 4

15 years ago
Some others page really slow on MacOs X, tested both on Mozilla 1.3b and on
Chimera (fast enough on Windows or with Safari) :
http://www.w3.org/Style/   (very very slow)
http://www.macgeneration.com/actu/ (slow)

Comment 5

15 years ago
Mozilla 1.3, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3)
Gecko/20030312, Windows XP Pro, Build 2600.xpsp1.020828-1920

Dell OPTIPLEX GX50, Celerron 1.2GHz, 256 MB RAM, Intel 82810E Graphics Controller

The URL reported WFM. The URLs in comment 4 are not that bad, but somewhat slow. 

See http://www.hiwaay.net/support/faq/index.cgi?view_category=1&catid=50 or
http://www.hiwaay.net/support/faq/index.cgi?view_category=1&catid=88
(or any other hiwaay.net page, for that matter) for pages that cause intense
CPU/kernel thrashing. 

The hiwaay pages scroll fine in Opera 7.03, IE 6, Amaya 7.2 & even Netscape 2.02(!).

Comment 6

15 years ago
On Windows Xp, build 2003032308, all url:s scroll very smooth. PIII, 800 Mhz,
Geforce 2 MX.

Comment 7

15 years ago
Mozilla 1.4a, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030401, Windows XP build 2600.xpsp1.020828-1920

update: all URLs scroll fine (WFM), including the hiwaay.net pages...

Comment 8

15 years ago
so, marking wfm?

Comment 9

15 years ago
2 other URLs that scroll far from smoothly :
http://www.linuxfr.org/
http://www.gloriousnoise.com/

(reports say that even on a bi-1.2 Ghz, it isn't smooth)

This bug seems to be MacOs X only (no slowdown at all on an old PIII 550)

Comment 10

13 years ago
*** Bug 275618 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
(In reply to comment #9)
> 2 other URLs that scroll far from smoothly :
> http://www.linuxfr.org/
> http://www.gloriousnoise.com/
> (reports say that even on a bi-1.2 Ghz, it isn't smooth)
> This bug seems to be MacOs X only (no slowdown at all on an old PIII 550)
IT HAPPENS TO ME ON WINDOWS XP. IT MAKES ME PUKE!I HAVE MSN SERVICE. AND E 
MACHINE

Comment 12

9 years ago
Is this bug still valid? Attached URL is smooth.

Comment 13

9 years ago
No more particular problem on any page since Gecko 1.9 has landed.
I think this bug could be closed. 
Assignee: saari → nobody
QA Contact: winnie → layout
(In reply to Vincent Nicolas from comment #13)
> No more particular problem on any page since Gecko 1.9 has landed.
> I think this bug could be closed.

WFM then.
Status: NEW → RESOLVED
Last Resolved: 15 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.