Use <HR> between msg body and text/plain attachment

VERIFIED FIXED in M12

Status

MailNews Core
Composition
P5
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: marina, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When you attach a local file (html format) to a message the text in the body and
the attachment look all fused together with no space or HL separating them (as
it is done for Plain text attachment)
Steps to reproduce:
-open new mail;
-type some text into the body;
-click Attach icon, choose html file from your local drive;
-send and get it;
//note : you can not tell where the mail body finishes and where attachment
starts (they are all fused together)
It is not happening when you're attaching a Plain text file (there is a HL
separating body and attachment)
(Reporter)

Comment 1

18 years ago
Created attachment 2891 [details]
an html file i used to test this case
(Reporter)

Comment 2

18 years ago
forgot to mention : this was obseved with 1999-11-15-20 M11 final candidate
build

Updated

18 years ago
Assignee: ducarroz → rhp
Rich, this one is for you...
(Assignee)

Comment 4

18 years ago
Is this a bug? This is the behavior we have today with 4.x. Do we want to
change that.

- rhp

Comment 5

18 years ago
I tried this with 4.7, and RHP is correct - the behavior described as a bug is
the same behavior we have in 4.7.

I don't think a horizontal line is necessary, but wonder if Jennifer has a
different opinion.

Comment 6

18 years ago
There is another question we should consider.
In 4.x, if the plain text part is followed by an html part in multipart/mixed type,
we insert an <HR> for displaying such a message. The tag is not in the source
and so it is something we are doing for display purpose in 4.x.
We don't seem to be doing that for Mozilla now.
What do others think about this for Mozilla?

Updated

18 years ago
Priority: P3 → P5
Summary: When attaching html file from the local drive mail body and attachment are fused → Use <HR> between msg body and text/plain attachment

Comment 7

18 years ago
> Is this a bug? This is the behavior we have today with 4.x

I'd be willing to call it a bug, but a very low priority bug
(Assignee)

Comment 8

18 years ago
I don't think this is true. If we have a multipart message with a text body and
an HTML attachment, there is a separator inserted with Mozilla.

- rhp

Comment 9

18 years ago
Today's Win32  build does not display with an <HR> between unlike parts.

Comment 10

18 years ago
4.x displays with <HR> only when parts are unlike, not when HTML part is followed by another
HTML part.
Phil, are you suggesting a more general display marker for Mozilla?
(Assignee)

Comment 11

18 years ago
I have a clean build from this morning and it does, so either something changed
there is a new bug.

- rhp

Comment 12

18 years ago
Or there might be an installer problem. I have had this happen to me a few
times recently. Some feature does not work on a first install but begins to work on
the 2nd install.

Comment 13

18 years ago
With regards to a <HR> between the message and the ONE HTML attachment:  A
horizontal line is not necessary but a couple of blank lines between the message
and the attachment should be inserted to make it look nicer and help users
distinguish between the message text and the attachment item.

As for <HR> BETWEEN attachments displayed inline, this would be nice.  Otherwise
the attachments displayed inline run together and its hard to tell where one end
 and the next begins.

For example: I send myself an email with 3 attachments (4.x): an html file, a
gif file and a txt file.  The message text and first html attachment has a
couple line breaks between them (fine), the html attachment and the gif
attachment have nothing between them (impossible to tell where one ends and the
next starts), the text file and the gif attachent have a <HR> between them
(nice).
(Assignee)

Comment 14

18 years ago
Well, basically, Mozilla should render all messages the same as it did in 4.x
with respect to horizontal lines. So, either this isn't a bug or its a very LOW
priority bug as phil mentioned.

- rhp

Comment 15

18 years ago
Rich, there is a bug for displaying <HR> between
unlike parts. I'm going to open a new bug for it.
It was not my build installation, the problem
was with "format=flowed" generated by Mozilla mail.
If you see a message of this type sent from 4.x,
you will see the <HR> separator between unlike parts.

Bug 19309.
(Assignee)

Comment 16

18 years ago
*** Bug 19309 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Use <HR> between msg body and text/plain attachment → FIXED: Use <HR> between msg body and text/plain attachment
Target Milestone: M12
(Assignee)

Comment 17

18 years ago
Ok, after a few margarita's, libmime made more sense than earlier in the day
and I've made this change. I will check in the fix when the tree goes green.

- rhp
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Summary: FIXED: Use <HR> between msg body and text/plain attachment → Use <HR> between msg body and text/plain attachment
(Assignee)

Comment 18

18 years ago
Should be fixed.

- rhp

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
Build 1999121308M12: NT4, Linux, Mac
Verified Fixed. I created a message that includes message text, followed by an
attached html file, a gif file and a plain text file. Viewing the message in 5.0
produces the same results as in 4.7: I see a horizontal line between each
segment and the area between the html and the gif file includes extra horizontal
spacing (not a horizontal line).

Note: There is a problem viewing a message with 2 gif attachments. They appear
too close to each other. There should be more horizontal spacing.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.