yahoo.com - in-page links do not work properly; and button bar on left displays misaligned buttons

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: John Gordon, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

NOTE: this problem was duplicated with the latest nightly build as of 1/19/03
1:10pm PDT.
In-page links such as "S-U (back to top)" in the above URL do not work properly:
each such link is supposed to jump back to the top of same web page in which it
resides (actually, a label near the top), but instead jumps out of the page to
its corresponding, normally-unused page.  Furthermore, such links show
underlined/hyperlinked under the entire name (e.g., "S-U (back to top)" instead
of only the designated and intended part "(back to top)."

Both Internet Explorer 6 and Opera 6.03 work correctly on this page -- i.e., the
links such as "S-U (back to top)" jump within the page they reside to an
alpabetical index on that page and each such link is shown underlined and
hyperlinked only on the intended part, "(back to top)" and not the part
preceding that (e.g., "S-U" or "M").

Reproducible: Always

Steps to Reproduce:
1.Visit above URL
2. Click an index "back to top" link such as "S-U (back to top)" 
3. Compare behavior to IE 6 or Opera 6.03, which handle these links as intended.

NOTE: The html code on the above URL is generated by Yahoo Store's interface; 
the in-page links with problems discussed here were html code added to the page
using Yahoo Store's design inferface (i.e., Yahoo Store takes the user-entered
code and embeds it in their design-manager-generated code.

Actual Results:  
See details above for actual results.

Comment 1

15 years ago
If this is a bug and not just bad coding then it's a Mozilla bug, not a
phoenix-specific problem. 
Assignee: blaker → aruner
Component: General → US Ecommerce
Product: Phoenix → Tech Evangelism
QA Contact: asa → bclary

Comment 2

15 years ago
The problem is due to invalid nested links and missing quotes around attributes
as in:

<a HREF="st.html"><h3><a name=S-U>S-U </a><a href="#top">(back to top)</a></h3></a>

This affects all builds afaik.

John, as a potential customer can you contact this store and ask them to correct
their HTML so that it does not use nested links as in 

<h3><a HREF="st.html" name="S-U">S-U </a><a href="#top">(back to top)</a></h3>


Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Updated

15 years ago
Keywords: evang500

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 4

15 years ago
John Gordon -- are you still there? Have you contacted the site?

This is still a problem, as far as I can tell. John -- I'm unclear on whether or
not you're the customer or proprietor of this site, since you know how the code
was generated. Have you contact Yahoo! about this at all?

If this is just a bug with the store's code itself, and not with Yahoo!, then
this probably shouldn't be evang500...

-M

Updated

15 years ago
Summary: in-page links do not work properly; and button bar on left displays misaligned buttons → yahoo.com - in-page links do not work properly; and button bar on left displays misaligned buttons

Comment 5

14 years ago
Looks fixed to me. The <a>'s are not overlapped and the links work.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.